Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 3 of 3 Posts

·
Registered
2004 chevy trailblazer_ltz
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey guys. Thanks in advance for helping me.

A few nights ago I was trying to get out of an icy parking lot, was slipping so I switched into 4Hi as it was an ice skating rink. Everything switched over just fine and I went on my way. Back on clean roads I switched back to 2wd and the light blinked as normal in transition, but after about 10-20 seconds of blinking it jumped back to 4Hi and stayed steady. I tried switching to A4wd which worked, but now it's stuck in a4wd- I try to switch it into 2wd, 4hi, even 4lo (in N) and all I get is blinking and then a jump back to steady over a4wd. The service light is not on, and only went on once for a split second and went off when I turned the car off and on again. It is not on now. Disconnected the battery for 10 mins to no avail.
Help!
 

·
Registered
2004 chevy trailblazer_ltz
Joined
·
3 Posts
Discussion Starter · #4 ·
Looks like I'll be replacing the encoder motor. Any tips on how to get the motor in properly as I can't set the switch to 2wd? Lookin over the forum I can see that there are some issues with things aligning properly if you can't get it in 2wd.
 

·
Registered
2004 chevy trailblazer_ltz
Joined
·
3 Posts
Discussion Starter · #7 ·
Tried the 2hi Key trick. No luck. Fluid was just changed 5k mi ago, no leaks. Level is good. Any tips for switching the motor when you can't get the transfer case into 2wd? Sounds like this can be a huge problem when trying to replace the encoder motor.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top