Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 2 of 2 Posts

·
Registered
2003 chevy trailblazer_ls
Joined
·
2 Posts
Discussion Starter #1
Hi All, I am looking for some help with my windshield wipers and my pride...

I have a 2003 trailblazer with rain sensing wipers. On my way home from work a week ago my wipers were on the intermittent setting and working great. Then they stopped. When I moved the switch up to high, they started very slowly and then stopped at 1:00. After I arrived home I gave them a push and they started working again. After shutting the Trailblazer down they have not worked since. I checked the fuses, both in the under hood fuse box and in the fuse box under the seat. I swapped out the #42 relay with a like one and still no change. I noticed the motor although not operating had a slight hum to it. I replaced the motor assembly with two different used ones from my local salvage yard. Both used motors have the same result, not movement but a steady hum. Does anyone have any thoughts? :bonk:
 

·
Registered
2006 chevy trailblazer_lt
Joined
·
76 Posts
Though this post is one and three quarter years old and I am just coming across this post, I have the answer to this:

The wiper motor pulse control board was what went. This electronic board is connected to the base of the windshield wiper motor and controls the intermittent timing. Mine went on my '06 Trailblazer and I replaced it with a new unit I bought off of Amazon.

This is the exact part for the subject vehicle, the 2003 Trailblazer:

 
1 - 2 of 2 Posts
Top