Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 12 of 12 Posts

·
Registered
2005 chevy trailblazer_ls
Joined
·
46 Posts
Discussion Starter · #1 ·
hello everyone,
im having a small problem im hearing a whining noise coming from the engine area mainly the middle were the fan is. Im having the engine light come on and off but it doesnt over heat. I moved the fan left to right motion and it wiggles does that mean my water pump is going bad? Any info is appreciated.
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
1,708 Posts
You are probably looking at replacing the fan clutch, but while you have it off it would pay to replace the water pump as well. The light that is going on and off is the check engine light? No codes have been set?
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
46 Posts
Discussion Starter · #3 ·
You are probably looking at replacing the fan clutch, but while you have it off it would pay to replace the water pump as well. The light that is going on and off is the check engine light? No codes have been set?
thanks robert for the info and yes it is the engine light that is coming on and off. I have the codes read before from autozone and it says it either a bad thermostat or just low on coolant but i check coolant and its fine.
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
1,708 Posts
When the fan clutch goes bad they tend to lock up and run fast, not slow. Interesting. You checked coolant in the radiator or the overflow?
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
46 Posts
Discussion Starter · #5 ·
What do you mean they tend to run faster not slower? I have checked both before and both have been good.
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
1,708 Posts
When they lock up they will sound like a jet engine, also described as sounding like a diesel truck, wound up. What does the temp guage on the dash say, do?
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
46 Posts
Discussion Starter · #7 ·
oh well no it hasnt lockd up yet and the tempature gauge says all sorts of temp. when i start it up it slowly goes up to 250 and then when i get on to the highway the damn thing drops to 110 and then jumps back up :weird:
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
1,708 Posts
Water pump and or the fan might not be working correctly. Can you put a scanner on it and read the real coolant temp (gauge might be bad)? Thermostat also might be sticking open at times. Hot and cold will set codes for the thermostat.
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
46 Posts
Discussion Starter · #9 ·
Water pump and or the fan might not be working correctly. Can you put a scanner on it and read the real coolant temp (gauge might be bad)? Thermostat also might be sticking open at times. Hot and cold will set codes for the thermostat.

:thx for the info robert and yeah ill see if i can scan it this evening.
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
388 Posts
I was told you need a special GM tool in order to take the fan off so that you can replace the fan clutch is this correct?
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
46 Posts
Discussion Starter · #11 ·
I was told you need a special GM tool in order to take the fan off so that you can replace the fan clutch is this correct?
i was doing some searching and I think so i cant remember the number tho. if you search "replacing fan clutch" u should find your answer in there.
Hope that helps
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
426 Posts
I am also having the same problem. i have this whinning/ whistle noise coming from the engine. It does it mostly when the rpms goes up and down. and lately i hear it very slightly when the car is in idle.

i heard from some posts it could be the water pump going bad.

i'm not to sure but i think it may be a fluid making that noise.

need some help!
 
1 - 12 of 12 Posts
Top