Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 20 of 24 Posts

·
Registered
2007 chevy trailblazer_ss_3ss
Joined
·
26 Posts
Discussion Starter #1
When my brakes are applied my brakes squeak only when i slightly apply the brakes but when fully applied it does not squeak. Does this mean I need new pads?
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
422 Posts
Take your tires off and check...

How far down does the pedal go?
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
164 Posts
I agree with 4x4forLife. The best thing to do is jack it up and pull the tires to see how much brake pad you have left. Also check the roatars t osee if they are warped or have any scars. If everything looks good it could be build up on the brake pads causing the sqeak. Might try using brake cleaner on the pads and then wipe them clean.
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
1,708 Posts
Under normal conditions the leading edge of the brake pad gets to a sharp edge and chamfering the edge will stop the squeek. Higher end pads come with a large chamfer to stop this for a very long time.
 

·
Registered
2007 chevy trailblazer_ss_3ss
Joined
·
26 Posts
Discussion Starter #5
Ok I brought the SS to the dealer and they said the brake pads are like brand new and they could not duplicate the sound. This only happens at low speeds say 25mph and below. Should I just take a look myself? Is there anything I can do if everything is normal?
 

·
Registered
2007 chevy trailblazer_ss_3ss
Joined
·
26 Posts
Discussion Starter #7 (Edited)
So you want me to cut the edge that is squeaking? I will get out the dremel to cut the edge down.
 

·
Registered
2007 chevy trailblazer_ss_3ss
Joined
·
26 Posts
Discussion Starter #8
ok I have checked all brakes which have a curve edge but still making squealing noises when i apply the brakes and when I dont apply the brakes. Could someone please help?:confused:
 

·
Registered
2007 chevy trailblazer_ss_3ss
Joined
·
26 Posts
Discussion Starter #9
Anyone willing to help would be appreciated.

If the weather is nice I will be taking the brake pads off once again and taking pictures. I did notice that the rotor is loose a bit once I take the wheel off. It has been a while since I have done work on my own vehicle. Should this happen with the loose rotor being like that?
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
96 Posts
Maybe its just dirt, get some good brake cleaner and spray everything down. Or I know autozone sells this little packet of brake quiet, but I have never used it or know if it really works. The loose rotor with the wheel off is normal, when you put your wheel on it will sandwich the rotor between the wheel and hub.
 

·
Registered
2007 chevy trailblazer_ss_3ss
Joined
·
26 Posts
Discussion Starter #11
There is no dirt from the last time I checked the brake pads. From the last time when I took the pads off I noticed there was a clip type on the brake pad. Is that for anything?
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
96 Posts
Just because you dont see any dirt doesnt mean that there is any. I dont know that the clip on yours is for, I havent put brakes on a TB yet but I have dont alot of brake jobs on others.
 

·
Registered
2007 chevy trailblazer_ss_3ss
Joined
·
26 Posts
Discussion Starter #13
Ok i have spoke with a chevy technician about the brakes. He said that the brake pad sensor (tab from what I said before) which is what is making the squeaking noise. My question which I should have asked the chevy tech is can you adjust the sensor?
 

·
Registered
2007 chevy trailblazer_ss_3ss
Joined
·
26 Posts
Discussion Starter #14
:thumbsup:

I figured out my issue... The shim on the back driver side brake pad was gone. No wonder why I am getting the noise I am hearing. Does anyone know of brake pads that wont need shims?
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
541 Posts
During very very high humidity I get a squeak on the first and second brake attempts. My pads seems well within spec.

If I drag the brakes lightly for about 1.5 seconds it ends the squeak. Only happens on high humidity. Dew just dripping like crazy off the paint.

I should knock my tires off and take a good look. On other vehicles I had, it would just make them sensitive until they were applied once or twice.

Anyone else live where its 90%+ humidity all night long?
 

·
Registered
2004 gmc envoy_slt
Joined
·
538 Posts
USUALLY when the brakes squeek when you do this, its just because of the type of pads you put on...when you start hearing the noise all the time thats when your down to the metal warning clip(if you or the person doing it reinstalled them)....they do make a gel type thing that you can put on to quiet them but if it really bothers you(it would me) just go buy good pads for the front and replace them....the noise isnt going away because of the way the pads wore down...it puts like an edge on them and thats the noise you are hearing


NOW THIS IS JUST USUAL SITUATIONS....YOU STILL NEED TO CHECK THEM TO MAKE SURE!!!

i have high humidity here and mine only make noise for a second if the vehicle has sat longer than a day...but it goes away before i even leave my neighborhood and its not even loud or really noticeable if you have the radio on even on very low
 

·
Registered
2006 gmc envoy_denali
Joined
·
119 Posts
im getting a squeek thats getting to me too. I jsut replaced my rotors and pads about a month ago and just last week it started squeeking... most of the time it does it at lower speed. Was just the drivers side and now i think its both sides. I got a higher quality set of napa ceramic pads ($60) and a sort of midgrade rotor from advance autoparts. I used plenty of the "squeek lube" on the back of the pads.. any ideas? Could a bad set of rotors cause it?
 

·
Registered
2004 gmc envoy_slt
Joined
·
538 Posts
did u use a lot of brake clean while and after to make sure u cleaned off all the rotors and pads? try it again....also if the pads weren't "burnt in" before you installed them and u didn't then that's the reason and you might be able to burn them now as long as u haven't already made a normal wear pattern
 

·
Registered
2007 chevy trailblazer_ss_3ss
Joined
·
26 Posts
Discussion Starter #19
Yes I used a lot of brake cleaner. I did noticed that my driver side rear brake pad is missing a anti vibrating clip well missing half of it. Does anyone know where I can buy one at?
 

·
Registered
2002 non_gmt360 other
Joined
·
344 Posts
I have this same issue, just replaced my back pads 1K miles ago, dut I don't remember there being any of those shims in the back pads. I'll pull off my tires and check all 4 brakes and maybe clean the rotors and pads as well. Will let everyone know if it works.
 
1 - 20 of 24 Posts
Top