Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 4 of 4 Posts

·
Registered
2006 chevy trailblazer_ls
Joined
·
2 Posts
Discussion Starter · #1 ·
I just bought a 2006 Trailblazer LS. The CEL came on Saturday, and I pulled the code. It is P0496 "EVAP purge during non-purge condition". So my first step was to look at the relevant components, and I found that the car is missing something.
A picture would be worth a thousand words, but I can't attach a pic until I have 5 posts, so I will try to describe it. The location is behind and below the ECM and in front of the brake booster. From the purge valve, there is a hard pipe that comes up to a 90 degree "fitting", and a hose that goes back down. The top of that "fitting" is threaded, but there is nothing attached to it. What is supposed to be there? A check valve? A vent filter? A hose?
Any help will be greatly appreciated.
Thanks --
-- Jim
 

·
Registered
2003 gmc envoy_slt
Joined
·
628 Posts
Looks like this...


The cap on yours may be missing. It will look like it has a tire valve stem in it.

That is a test port connection for the EVAP system. A tech connects a machine to it to confirm that the system is holding pressure. Useless to you unless you have the machine to connect to it.
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks, AWD. I will add that dust cap to my list for the next trip to the junkyard.
I replaced the purge valve last night, and I am reasonably sure that was the problem, since I could blow right trough it. Should know for sure in a couple of days.
Thanks again!
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top