Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 7 of 7 Posts

·
Registered
2006 chevy trailblazer_ss_ls
Joined
·
313 Posts
Discussion Starter #1 (Edited)
so i was pulling off a corner street and decided i wanted to hear the truck roar (cut out was open) so i get on it and it goes from first into second but when it went from 1st to 2nd it felt like it lost all its power then regained it and when that happend the light that comes on when you turn your traction control off blinked i think 4 times and everything went back to normal ( i have extended warranty so i tried to reproduce the problem) but this time it shifted normal with no lights and no loss of power...im kinda afraid here because i dont want anything extremely bad happening and having to pay the stealership for some problem. when i got home i popped the hood with it running and everything seemed fine but i did notice that the oil pressure doesnt run just at 40 when i am driving it runs about 45 now. idk if the oil pressure has anything to do with that problem im just so use to my jeep and it ran at 40 constantly and never changed......would anybody happen to know what may have happend or if i am looking at any issues arising out of this :cry:

at first i thought i lost my trans....thank god i didnt :hail: :woohoo:

or does tc and st shut your car down

i read this while searching so could it be that the tc and sc shut the car down



If the traction control is off, the light on the dash will be on. Its a little triangle with 2 squiggly lines through it. If the stabilitrak is off it will flash for a few seconds, then remain solid. When both are on, and your traction control/stabilitrak kicks in, the light flashes. Otherwise the light stays off.
found it here
http://www.tbssowners.com/forums/showthread.php?t=7917

seems to be the problem by reading that

but if anybody would like to shine in on it be my guest, because if that is not the problem.....it looks like im up **** creek without a paddle.

and if this is the reason for this happening....has anybody put a inline switch to disable tc and st by the flip of the switch rather than going under the hood and popping the fuse?
 

·
Registered
2009 chevy trailblazer_lt
Joined
·
1,349 Posts
it sounds like you lost traction on one or more tires. thats why traction control kicked in.
there should be a button on the shift to turn off th tc & st. mine is just below the button you use to take it out of park. :m2:
 

·
Banned
2007 chevy trailblazer_ss_1ss
Joined
·
2,006 Posts
:crackup::crackup::crackup::crackup:

you just lost traction my friend... i can guess you've never driven in the snow... or wet pavement that much... the ST, TC is a safety option that will kill power if tires break free... and you mentioned you punched it turning a corner.. your 2WD so of course tires will break with more then 300 ponies comin out... did you feel the tires breakin at all or hear a little churping??... if not thats ok... when the vehicle senses that things are getting out of control... BOOM.. you lose power... (trust me, ive been in the snow and ST kicks in and i put my foot to the floor, and the truck didnt move!!)

as stated above you dont need to pull fuses all the time (just when racing at the track).. on your shifter knob underneath your Chrome Button that you push in to move the gear selector, is a little button.. hit it once and the TC will turn off... Hold that button in for 5 seconds and you will see your TC/ST light blink, then stay on solidly and your DIC will read "Stabilitrac Off", not "Traction Control Off" that you would be used to seeing when just hitting the button compared to holding it...

this happens to me alot (especially now that im tuned) when i want to get on it ar get into a little fun.. depending on where my RPM's are and what gear im in.. when i punch it ill churp the tires as the tranny shifts.. then the TC light kicks on....

on a side note there have been known problems in the past with the ST light coming on at random... but it will stay on, meaning to get it serviced... so just be on the look out for that... but if it hasnt happened since you did it, and you cant duplicate it.. then you have nothing to worry about...
 

·
Registered
2006 chevy trailblazer_ss_ls
Joined
·
313 Posts
Discussion Starter #4
well i never had that happen before so i was like oooooooh **** lol but yea i knew how to turn them both off before it happend its just i never had that happen lol no i didnt feel them break free but 2nd gear torque was very mean then the truck shut down...i guess they began to spin in second so it shut it down. hmmm there was no water either, just dry west texas streets
 

·
Registered
2006 chevy trailblazer_lt_ext
Joined
·
1,357 Posts
The same thing happened to me tonight actually... pulled out of a parking lot while accelerating and POW! the traction light came on... I looked down at the DIC and was prompted with the "Service Stabilitrak" display... :confused:

I'll check for the "reset" button on the shifter in the morning and hope that "clears" the message... if not, I guess I'll bring it into my mechanic and see what he says... :worried:
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
541 Posts
My service stabiltrak light has come on a couple times when pulling hard out in traffic with a sharp right turn. They might even be a tsb on it. I just clear the codes from my scan gauge
 

·
Registered
2006 chevy trailblazer_lt_ext
Joined
·
1,357 Posts
My service stabiltrak light has come on a couple times when pulling hard out in traffic with a sharp right turn.
That's exactly what I was doing too: turning right... odd.

They might even be a tsb on it.
If there is, would I be able to find it on this site somewhere? Any idea?

I just clear the codes from my scan gauge
How do you do that? Is it easy to do or should I just bring it to my mechanic instead?
 
1 - 7 of 7 Posts
Top