Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 8 of 8 Posts

·
Registered
2002 chevy trailblazer_lt
Joined
·
515 Posts
Discussion Starter #1
New to me 2002 LTZ Great shape.
Left turn signal does not work. Started with the bulb, then the bulb holder circuit board, fuses.
All good. When I turn on the flasher only the right works. No green arrow flash in the instrument panel either.
Is it the switch or am I missing something?
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
1,054 Posts
You checked the left turn fuse #38 in the rear fuse block under the back seat?


Both front and rear don't work? Park lights work for that same bulb?
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
515 Posts
Discussion Starter #3
You checked the left turn fuse #38 in the rear fuse block under the back seat?


Both front and rear don't work? Park lights work for that same bulb?
w
You checked the left turn fuse #38 in the rear fuse block under the back seat?


Both front and rear don't work? Park lights work for that same bulb?
No signal front or rear. Fuses good
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
1,054 Posts
If you have 12 volts DC power that blinks on and off with the left turn signal specifically at that #38 left turn fuse, and the signals don't flash, then you have a wiring issue. You can see in this picture the wire goes directly from that fuse to the light bulb. Could also be the ground. That's why I asked about the park lamps, they use the same ground.

If you do not have 12 volts power at that fuse with the signal turned on then the problem is upstream of that point.

Screenshot_20210225-163501.png
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
515 Posts
Discussion Starter #5
If you have 12 volts DC power that blinks on and off with the left turn signal specifically at that #38 left turn fuse, and the signals don't flash, then you have a wiring issue. You can see in this picture the wire goes directly from that fuse to the light bulb. Could also be the ground. That's why I asked about the park lamps, they use the same ground.

If you do not have 12 volts power at that fuse with the signal turned on then the problem is upstream of that point.

View attachment 56562
Thanx
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
1,054 Posts
I would have to say the most likely thing to be the problem given what you have tested out would be the multifunction switch itself. That or a bad wire from the turn signal switch to the flasher module.
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
515 Posts
Discussion Starter #8
OK, there was no diagram inside the rear fuse box, so I didn’t see fuse 38.
it was missing! Plugged one and it works. I had checked the front box and didn’t pay close attention as the left and right turn signal fuses are for the trailer light connection.
I am officially getting old! 😜
Thanx for the help!
 
1 - 8 of 8 Posts
Top