Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 4 of 4 Posts

·
Registered
2005 chevy trailblazer_lt_ext
Joined
·
695 Posts
Discussion Starter · #1 ·
During my standard pre-trip inspection I discovered that my trailer signal lights weren't working properly. Left turn works but right turn flashes both right and left signals. Brakes and running lights work properly. I took the test light to the trailer plug at the back of the truck and the problem exists there so it's not a fault in the trailer.

I suspected a fuse problem and checked the under seat and under hood fuses. Fuses were good. But I noticed later that my right turn signal without the trailer now occasionally flashes right and left on the truck, without the trailer.

For the life of me I can't figure out where to look next. Any ideas from the gurus out there? Thanks in advance.
 

·
Registered
2009 chevy
Joined
·
6,431 Posts
Here is what you need to consider, the truck has separate brake and sig lights. The trailer use the same bulb. How does the trailer plug convert 2 wires into one? :undecided

Answer, the flasher does it.

You might have a problem with the flasher.

But, try the simple first. Check the back side of the trailer plug, maybe you have dirt/etc that's shorting the connectors.
 

·
Registered
2005 chevy trailblazer_lt_ext
Joined
·
695 Posts
Discussion Starter · #3 ·
By backside of the trailer plug do you mean under the flap where the pins are? If not, how do you access the back? Does it just unplug?

Flasher? Could be. I know in my last van I had to buy an adaptor that combined the 2 bulbs on the van into 1 bulb for the trailer. Hadn't thought of that. Could that cause problems even with the trailer unplugged?
 
1 - 4 of 4 Posts
Top