Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Anyone had the tranny shift with a jolt or shudder from 1st to 2nd gear change under light to medium throttle? While under warranty told dealership about this and its documented the problem is occuring, when they drove it could not duplicate the problem. This was going on when under warranty and only occurs intermittently now have 76k on it and going to get the dealer to service trans flush here soon, dealership has done all the service on this, except me changing the air filter. Any suggestions from anyone on the shifting issue?
 

·
Registered
2005 chevy trailblazer_lt
Joined
·
9 Posts
That sounds like what was happening to mine in the past. When I turned off the car, it would shift normally. They changed a wiring harness the last two times. This time a bearing got loose and did more damage.
 

·
Registered
2002 chevy trailblazer_ls
Joined
·
2,461 Posts
I have had something like this since my latest pcm re-tune. It feels like it is slipping or not engaging quickly enough from 1st-2nd after it has warmed up. This doesn't usually happen right away, usually only after a few miles. My stock pcm doesn't do this however.
 

·
Registered
2003 gmc envoy_slt
Joined
·
527 Posts
I have had something like this since my latest pcm re-tune. It feels like it is slipping or not engaging quickly enough from 1st-2nd after it has warmed up. This doesn't usually happen right away, usually only after a few miles. My stock pcm doesn't do this however.
I have not changed my PCM either and mine does it. I would like to figure out if somethings wrong, or if its just normal. I have changed my tranny fluid to Synthetic fluid. But im pretty sure it did this before i changed it. It dosnt feel like its a BAD shift, just sorta abrupt and more firm then all the rest of the gear. Anyone agree with that description?
 

·
Registered
2002 chevy trailblazer_ls
Joined
·
2,461 Posts
Hmm, well since that last post of mine I sent my pcm back for a complete retune. It definitely helped get rid of the slipping, but now I have a clunk on my down shift every time I hit 15mph. They can't seem to figure out why as there tuning shows it should be working fine. I just hope its not tearing up my tranny in any way, but my fluid is still pretty redish at 100k now. Will be replacing some of that here soon.
 

·
Registered
2003 chevy trailblazer_lt
Joined
·
130 Posts
My buddy works on Trans he looked at mine and said that one of the valves was flaring up and that it was causeong it to shift rough after repairing it I didnt have any more issues.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top