Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey guys, was camping over 4th of July weekend.
2003 Trailblazer LTZ 4.2l 4x4
On the way back into town, only about 20 miles from home, I noticed that while in overdrive, my RPM kept bouncing between 2000-2200 while cruising at 55. So I kicked it into third and it was fine. Then, coming back into town, I hit a stop light, when I slowed down, I did downshift to second, and it shifted really fast and hard. Then at the light put it back in third once stopped. When I accelerated off the light, the 1-2 shift and the 2-3 shift were extremely hard and fast, like a big jolt. Kept doing it on the way home.

Any ideas?
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
500 Posts
Hey guys, was camping over 4th of July weekend.
2003 Trailblazer LTZ 4.2l 4x4
On the way back into town, only about 20 miles from home, I noticed that while in overdrive, my RPM kept bouncing between 2000-2200 while cruising at 55. So I kicked it into third and it was fine. Then, coming back into town, I hit a stop light, when I slowed down, I did downshift to second, and it shifted really fast and hard. Then at the light put it back in third once stopped. When I accelerated off the light, the 1-2 shift and the 2-3 shift were extremely hard and fast, like a big jolt. Kept doing it on the way home.

Any ideas?
Codes?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
No codes, hooked up hptuners to it and found nothing. It's not doing it anymore, thinking maybe I heated up the clutch packs and it shifted hard to minimize slipping? Lots of steep hills with fast moving traffic and loaded fairly heavily. Maybe just a self protection mode? Dont know if anything like that exists, but it's back to normal now.
 

·
Registered
2003 gmc envoy_slt
Joined
·
4 Posts
When was the last time you flushed and replaced the trans fluid?
I had a clunk going into 2nd which was fixed by this.
Also, was it very hot out when this happened?
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
500 Posts
When was the last time you flushed and replaced the trans fluid?
I had a clunk going into 2nd which was fixed by this.
Also, was it very hot out when this happened?
People never can seem to learn that changing the trans fluid doesn't fix anything.
 

·
Registered
2008 chevy trailblazer_ls
Joined
·
6 Posts
Did you check speed sensor, as I have the same issue and local dealer says it's cos of speed sensor and throws code 716 & 717
 

·
Registered
2004 chevy trailblazer_ls_ext
Joined
·
58 Posts
If it were my truck and it's been say 40K since the last fluid change, I would do a pan drop and filter change. While I was in there, I would replace the A&B shift solenoids. Very easy to do and about $16 each on Amazon. Google 4l60e shift solenoid.

Some will say throwing parts at a vehicle is not the way to go. Agree, but for the price and the possible pay-off, this is what I would do.
 
1 - 9 of 9 Posts
Top