Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 6 of 6 Posts

·
Registered
2004 chevy trailblazer_lt_ext
Joined
·
2 Posts
Discussion Starter #1
This is my first my first post but I do appreciate all the help you all have given me in the past. My 04 Trailblazer has always been good to me but I ran into a snag at 147k miles. I had the transmission and filter, transfer case and diff fluid changed at 75k mile. I was driving back on the highway from PA to SC and it just started to rev like it was in neutral. It just happened with no warning. I pulled off to the side of the road and had it towed to my house. It will not engage as I go from Park all the way to 1st. I was told it was a planetary gear set from a mechanic and the transmission needs to be replaced. I am hoping this is not the case as I do not want to spend $2,000 to get this done. Any help would be appreciated. Thanks.:thx
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
You might have an unreasonable hope what we (basically blind since we can't touch or see your vehicle) can offer over a local mechanic.

Was the tranny fluid level OK while you checked it beside the road? When was the last time you checked it if it was low?

Since the transfer case fluid change interval is 50K, not 100K, could it be possible that it's dry and dead internally, and it's not the transmission? TCs are cheaper than trannys. Have you checked transfer case fluid level in the last 72K miles?
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
286 Posts
From your post sounds like you also reverse also?
 

·
Registered
2004 chevy trailblazer_lt_ext
Joined
·
2 Posts
Discussion Starter #4
The mechanic I talked to is a friend who is a GM mechanic and actually hasnt looked at the vehicle but gave me advice over the phone. I check the fluid level regularly and checked it before I drove from Pitt like I normally do with all fluids before long drives. I checked it on the side of the road and it was normal level. I have not checked the TC fluid in the last 72k miles but will go out now and check it.
 

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
1 Posts
sounds familiar

My 2005 just started acting up yesterday... When moderately accelerating in 1st gear/drive, the engine revs with a stange noise but vehicle is barely moving. Let up on the gas, accel slowly, then it gets moving again. You can also smell tranny fluid, but no leaks. Fluid is full, and does not smell burnt. At first I thought I knocked a line loose when installing a new water pump over the wknd, but again, no leaks...

Have about 115K, I did filter change and flush at about 98K, pulled a small boat couple times last summer, but other than that, just the wifes grocery getter. I installed a mild tune about a year ago, which firms the tranny shifts, not sure if a negative impact or not...

Will be checking with a friend tomorrow, who is a tranny guy at a GM dealer.
 

·
Registered
Joined
·
1 Posts
Looking forward to your results...my 04 TB transmission, last night, suddenly "disconnected" it's self. No pull at all...going this morning to recover and diagnose TB
 
1 - 6 of 6 Posts
Top