Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

21 - 23 of 23 Posts

·
Registered
2004 chevy trailblazer_ls
Joined
·
1 Posts
I have a 2004 trailblazer that had a rebuilt transmission put in 20,000 miles ago. It won't shift into high gear. I have already changed the gear shift solenoid without it making any difference. The pan didn't have any debris.
 

·
Registered
Joined
·
2 Posts
I have a 2002 trailblazer. The transmission seems to be fine in 1st and 2nd, but won't shift into 3rd or 4th. Today, we pulled the pan and changed the filter. The filter was pretty clogged, but there wasn't any metal in the pan, and the fluid wasn't burned. We also looked at the torque converter through the inspection port, and everything was clean. We are stumped. Any help would be good.
3-4 clutch packs are bad due to hard or worn out piston seal on the 3-4 pack . When the seal gets hard the fluid leaks by the seals and doesn't engage the 3-4 clutches hard enough . Which burns up the 3-4 clutches.easy fix but does require pulling trans out and apart.
 

·
Registered
Joined
·
2 Posts
I have a 2002 trailblazer. The transmission seems to be fine in 1st and 2nd, but won't shift into 3rd or 4th. Today, we pulled the pan and changed the filter. The filter was pretty clogged, but there wasn't any metal in the pan, and the fluid wasn't burned. We also looked at the torque converter through the inspection port, and everything was clean. We are stumped. Any help would be good.
If you have no forward gears you have a broken sun gear in trans . Still requires pulling trans . There are three well know problems with the 4l60e . Those are two I listed . Hope this gets you fixed.
 
21 - 23 of 23 Posts
Top