Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Thanks to this forum help I got my 05 Trailblazer ext ls running.

My cruise control is not work all my fuses are OK.

Were should I start to find the issue is there a common part or issue with cruise control on the 05 Trailblazer ext LS with 4.2L l6?
 

·
Registered
2007 chevy trailblazer_ls
Joined
·
340 Posts
First easy check, are your brake lights on? Now that the easy test says nothing wrong there I would suspect the switch on the stalk. That was what was wrong with mine when I bought it. But you could get lucky and it is just a connector issue.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
Had time to check today

1.) No light indicating the cruse is on
2.) Fuses OK
3. Brake light not stuck on

Could this be the the switch?

On the 05 trailblazer cruise is on the blinker switch with the front wind shield wipers and brights and dims.

The old style cruise not on the steering wheel were you press the end button to set cruise speed.

The wipers, bright/dim and blinkers work OK.

No engine light or error codes.
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
43 Posts
The "brake light switch" is actually 3 separate switches in the one housing. The set of contacts for the actual brake lights don't interact with the contacts that disengage the cruise control. So even if your brake LIGHTS work normally the contacts that release the cruise control could be faulty.
 

·
Registered
2002 chevy trailblazer_ltz
Joined
·
2 Posts
I have 02 t/b let model my cruise was not working also found that when the stereo system was put in the wire that goes to the cruise control was cut near the steering column.. replaced wire works great, that was a tough one to find the problem after changing cruise switch checking fuses multiple times.
 

·
Registered
Joined
·
2 Posts
Wheel sensors

Mine started having problems right after replacing a rotor. Never had any trouble before that. It's not completely dead but it turns itself off shortly after engaging the CC. I didn't want to go through the work of removing it and returning it so I just lived with it.
 

·
Registered
2003 chevy trailblazer_lt_ext
Joined
·
1 Posts
I second the damaged / missing wire. I bought a 2003 trailblazer about 6 years ago, and the cruise never worked on it. I replaced the brake switch, the turn signal stalk, and was considering replacing the cruise control module.

Ended up finding a wiring diagram online, tested for voltage at the brake switch, and found a cut wire up under the dash.

Interestingly enough, I suspect it was also cut during a stereo install.
 

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
1 Posts
I have the 2005 EXT as well. Mine was the switch on Transmission. $40 part. Easy to get too. I think it is on the top of the transmission on the passenger side Been a few years since the replacement and still going
 

·
Registered
Joined
·
3 Posts
Cruise Control

We have an '04 TB LS and when the yellow service indicator light comes on the dash for any reason the CC stops working. When I stop at the parts supply store and they clear the codes on the computer the CC starts working again. Lately the code is something about the fan clutch. But that has been checked and it's OK. My '04 was a police under cover vehicle and they had multiple electronics in it including an after market radio. So, I haven't tried to trouble shoot why the CC keeps checking out. I just clear the codes and it works until it decides not to again. Otherwise it has been a good car with 147K.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #13 (Edited)
Worth checking out!

I have 02 t/b let model my cruise was not working also found that when the stereo system was put in the wire that goes to the cruise control was cut near the steering column.. replaced wire works great, that was a tough one to find the problem after changing cruise switch checking fuses multiple times.
I'm going to look at this the my trailblazer has a after market stereo installed when I got t.

Life got me busy going to look into everything everyone suggested.

Also no cruise light comes on or codes given on my cruise control it just does nothing?

Not sure what fuse is the cruise control so I pulled and checked them all even the fuse box under the drivers side second roll seat.
 
1 - 13 of 13 Posts
Top