Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 20 of 20 Posts

· Registered
2003 Chevrolet Trailblazer EXT
Joined
·
6 Posts
Discussion Starter · #1 ·
2003 EXT with what seems to be common TPS codes and REP. We replaced the sensor as well as the pedal, did a reset and she STILL is going into limp mode and throwing one TPS code. We are at a loss as to what to do next. Any ideas or suggestions would be greatly appreciated as this is our only vehicle at the moment. Thank you!
 

· Registered
2002 chevy trailblazer_lt
Joined
·
2,163 Posts
There are two sensors in the throttle body. There are two sensors in the accelerator pedal assembly. There are also sensors in the cooling fan system, the fuel tank, the high pressure side of the A/C refrigerant system, and also the intake manifold.

All of these sensors get their power from two separate 5 volt power supplies in the PCM.

If any one of these sensors or any associated wiring to these sensors fails and shorts out one of the power supplys it will almost definitely cause a throttle or accelerator pedal (or both) DTC to set and cause "reduced power" mode. Under some circumstances it can also cause the engine to shut off.

The fault does not need to be a continous fault, it could exist for less than a second and still cause the DTC code(s).

That is the problem. A fault that is not in the accelerator pedal or throttle system can cause a DCT for the accelerator and/or throttle system. And when you go looking for the trouble it isn't there because it is intermittent.

One of the common causes is the cooling fan speed sensor. Everyone blames the cooling fan clutch but in reality the clutch does not use the 5 volt power, the speed sensor does. Nonetheless when the wiring to this device rubs through its' insulation practically nobody repairs it they just replace the whole unit.

Often it is suggested that one try unplugging the wiring harness to the fan unit to see if the accelerator or throttle codes go away, and stay away. This will likely set a code for the cooling fan but it can help in locating what is causing the reduced engine power mode. Just don't drive around a whole lot with the cooling fan unplugged as the engine could overheat and the A/C refrigerant pressure may run high if you aren't travelling at high speeds where the air is forced through the radiator and A/C condenser sufficient to prevent those adversities.
 

· Premium Member
'05 TB 4.2 EXT
Joined
·
6,192 Posts
Until I get off my nethers and decide to work in the cold and possible snow --- I'll maybe not change the fan for the one I just bought.
Creature comfort is important and besides, I'm retired.​

BUT --- I now know (like TJ said) that the REP and CEL is caused by my fan.

I only condemned it after almost 4 years - as the problem because it's dragging the 5V system to it's knees --- maybe one second - or even a half second at a time.

It was so-o-oooo bad that I got into plugging in a code reader every time I started the engine --- and then I could clear the code and continue running in just a few moments.

FUN FACT ---> when the REP light comes ON --- smash the throttle to the floor so you can at least keep some of the speed you were going, going.
If you take your foot off the throttle --- THEN you're gonna be doing 19.3MPH in a few minutes.

Here's a funny thing too ---> I though that using the Cruise Control was part of the trouble --- but it just didn't make any sense to me how.
I most times just dismissed that thoght until I used CC and the REP/CEL came back --- see the way I was confused?​
 

· Registered
2003 Chevrolet Trailblazer EXT
Joined
·
6 Posts
Discussion Starter · #4 ·
Ok. Unplugged the fan, same issue. Did the computer reset again, same thing.
Short of replacing random sensors and playing roulette with this thing, is there anything else we can do?
 

· Registered
2002 chevy trailblazer_lt
Joined
·
2,163 Posts
Ok. Unplugged the fan, same issue. Did the computer reset again, same thing.
Short of replacing random sensors and playing roulette with this thing, is there anything else we can do?
Do you own a meter of some sort or one of those inexpensive bluetooth ELM OBD2 adapters? Either of these could be of use in trying to find out where the issue is.

This may seem strange to you, but it is actually better that you get the code right away because it may make finding the cause easier rather than chasing a problem that is not always there.

Can you post here the actual alpha-numeric code(s) here, not just a verbal description? Like "P2135" or similar?
 

· Registered
2003 Chevrolet Trailblazer EXT
Joined
·
6 Posts
Discussion Starter · #6 ·
We don’t own anything like that, we’ve been having to run it to autozone every time, (fortunately only 2 mi. away).
Funny thing: I took the TPS sensor off again (just because I was so frustrated) and did the reset again, it’s running fine again.
This is so intermittent, it’s crazy. He had to go to work, so we’ll see how she runs on the way home. I’ll have him stop by and have them read codes before coming home. As it stands now, all lights are off and she’s back to normal. 🙄
Never imagined I’d have a vehicle more temperamental than me. 😂
 

· Registered
2003 Chevrolet Trailblazer EXT
Joined
·
6 Posts
Discussion Starter · #8 ·
Gotcha.
Ordered one, should be here Wednesday.
Out of curiosity, will it throw those codes if the actual throttle body is going? Any particular signs of that to look out for?
 

· Registered
2003 Chevrolet Trailblazer EXT
Joined
·
6 Posts
Discussion Starter · #9 ·
Do you own a meter of some sort or one of those inexpensive bluetooth ELM OBD2 adapters? Either of these could be of use in trying to find out where the issue is.

This may seem strange to you, but it is actually better that you get the code right away because it may make finding the cause easier rather than chasing a problem that is not always there.

Can you post here the actual alpha-numeric code(s) here, not just a verbal description? Like "P2135" or similar?
The codes this afternoon were:
P1125 Accelerator Pedal Position
P2135 Throttle Position (TP) Sensor 1-2 Correlation
It also recommended a TBI base gasket which we went ahead and did just for the fun of it.
😂 Can’t hurt, right?
It’s the whole Throttle Body, isn’t it?
 

· Registered
2002 chevy trailblazer_lt
Joined
·
2,163 Posts
The codes this afternoon were:
P1125 Accelerator Pedal Position
P2135 Throttle Position (TP) Sensor 1-2 Correlation
It also recommended a TBI base gasket which we went ahead and did just for the fun of it.
😂 Can’t hurt, right?
It’s the whole Throttle Body, isn’t it?
P1125 as you see is not a throttle body code.

P2135 is a throttle body sensor issue where the TWO sensors in the throttle body are reporting voltages that don't reconcile with each other. However, this DOES NOT immediately mean the throttle body is bad or even that the sensors are bad.

Each of the two throttle body sensors and each of the two accelerator pedal sensors are supplied 5 volt references from the TWO power supplies.

So one throttle sensor gets 5 volts from supply #1 and one throttle sensor gets power from supply #2.

Same for the accelerator pedal sensors. One sensor is powered from supply #1 and the other pedal sensor is powered from supply #2.

If any other system in the truck that uses these same two power supplys or the wiring to them causes a loss of power on either one of these two power supplys you will get these codes. Even if there is nothing wrong with the throttle body or accelerator pedal.

The job for the troubleshooter is to determine where the real issue is by logical testing.
 

· Registered
2003 Chevrolet Trailblazer EXT
Joined
·
6 Posts
Discussion Starter · #12 ·
Then she’s dead in the water then.
I have NO idea about electrical nor how to track down and fix that. 😞
Can’t afford to take her to the shop.
Thanks you guys. I appreciate the help.
 

· Registered
2007 chevy trailblazer_ls
Joined
·
73 Posts
You really need a scanner that shows live data and better yet has a graphing function. I have a relatively inexpensive scanner, a Launch 429C (about $250), but over the years it's saved me and other people way more than it cost.
Anyhow, the scanner can show the graphs of how the TPS sensors react to pedal input. You'll spend way more money throwing parts at the car than the cost of the scan tool, and still not fix because you didn't actually diagnose the problem.
 

· Registered
2004 isuzu ascender
Joined
·
7 Posts
There are two sensors in the throttle body. There are two sensors in the accelerator pedal assembly. There are also sensors in the cooling fan system, the fuel tank, the high pressure side of the A/C refrigerant system, and also the intake manifold.

All of these sensors get their power from two separate 5 volt power supplies in the PCM.

If any one of these sensors or any associated wiring to these sensors fails and shorts out one of the power supplys it will almost definitely cause a throttle or accelerator pedal (or both) DTC to set and cause "reduced power" mode. Under some circumstances it can also cause the engine to shut off.

The fault does not need to be a continous fault, it could exist for less than a second and still cause the DTC code(s).

That is the problem. A fault that is not in the accelerator pedal or throttle system can cause a DCT for the accelerator and/or throttle system. And when you go looking for the trouble it isn't there because it is intermittent.

One of the common causes is the cooling fan speed sensor. Everyone blames the cooling fan clutch but in reality the clutch does not use the 5 volt power, the speed sensor does. Nonetheless when the wiring to this device rubs through its' insulation practically nobody repairs it they just replace the whole unit.

Often it is suggested that one try unplugging the wiring harness to the fan unit to see if the accelerator or throttle codes go away, and stay away. This will likely set a code for the cooling fan but it can help in locating what is causing the reduced engine power mode. Just don't drive around a whole lot with the cooling fan unplugged as the engine could overheat and the A/C refrigerant pressure may run high if you aren't travelling at high speeds where the air is forced through the radiator and A/C condenser sufficient to prevent those adversities.
I finally took my 2004 Ascender in for the same thing. I had changed the throttle body and the accelerator pedal with their associated sensors and it was still limping. The shop said it was the fan clutch shorting out the 5V reference voltage they have in common. They drove it around and said it’s not limping anymore. I’ll find out for myself if that fixed it or not.
Brook
 

· Premium Member
'05 TB 4.2 EXT
Joined
·
6,192 Posts
Then she’s dead in the water then.
I have NO idea about electrical nor how to track down and fix that. 😞
Can’t afford to take her to the shop.
Thanks you guys. I appreciate the help.
Wait a minute ---- is that a pix of you?

Eyelash Ear Bangs Layered hair Smile


Is that a selfie? If it isn't --- are you left-handed?

(FTR ---> it makes a big difference)
 
1 - 20 of 20 Posts
Top