Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 8 of 8 Posts

·
Registered
2004 gmc envoy_slt_xl
Joined
·
3 Posts
Discussion Starter · #1 ·
So, my wife calls me and says the truck shutdown while she was driving. The DIC threw "Brake System Failure" at her or something like that. Of course, she had to manual steer it to a stop on the side of the road. The truck would not start anymore. Turn the key and nothing....no noise, no new codes on DIC...nothing. Had it flatbedded to the stealership and am awaiting a call.

A little history - Had the thermostat and BCM replaced in the last 7 months (~3K miles). Just had the brake pads "checked" in the last 2 weeks as well as a strange noise/grind when the A/C is turned on. They couldn't replicate the A/C noise for some reason on the last shop visit.

Just wondering if anyone else has had similar issues or any thoughts on what it could be. Oh, the truck has just over 76K on the clock.

Thanks.
 

·
Registered
2004 gmc envoy_slt_xl
Joined
·
3 Posts
Discussion Starter · #2 ·
Well, surprisingly the service advisor called me this afternoon and said the truck was ready. This time it was the PCM and thankfully it is also and 80K warranty part, so there was no cost to me. I did't get to pick up the truck and wont' be able to now, until Monday. Hopefully this is a happy end to a messy start to the weekend.
:thumbsup:
 

·
Registered
2006 chevy trailblazer_lt
Joined
·
713 Posts
nothing like a nice, cheap mod..:dielaugh:

seriously though, good to hear it was relatively painless... all of the stealership stories lately have been pretty mean and full of :mad: and :( and :hissy: faces, haha.
 

·
Registered
2004 chevy trailblazer_ls_ext
Joined
·
16 Posts
Happened to me ECM fault found, restarted in 5 minutes

Oddly I've the same year TB 4.2L with about 80K. It just died at a stop light. had to wave folks around me and smile. Tried key several times and it just did nothing. Quite as a church mouse. Waited a bit more. Shut key off and removed it from lock. Opened door, Closed Door. Restarted and went directly to Autozone. Code was ECM(?, engine computer) failure. Somehow it recoverd?
I also had BCM replaced when lowbeams died in 2007 at abotu 40K miles.(HBeams OK though). I thought it was just a relay gone bad by stealer stated they replaced BCM.
 

·
Registered
Joined
·
8,781 Posts
Oddly I've the same year TB 4.2L with about 80K. It just died at a stop light. had to wave folks around me and smile. Tried key several times and it just did nothing. Quite as a church mouse. Waited a bit more. Shut key off and removed it from lock. Opened door, Closed Door. Restarted and went directly to Autozone. Code was ECM(?, engine computer) failure. Somehow it recoverd?
I also had BCM replaced when lowbeams died in 2007 at abotu 40K miles.(HBeams OK though). I thought it was just a relay gone bad by stealer stated they replaced BCM.

common symptom of a faulty ignition switch..

cheap and easy replacement
 

·
Banned
2003 gmc envoy_slt
Joined
·
7,190 Posts
Another vote here for the ignition switch. Especially the part about turning the key and nothing happening.:m2:
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top