Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 5 of 5 Posts

·
Registered
2005 chevy trailblazer_lt
Joined
·
46 Posts
Discussion Starter · #1 ·
I have just replaced the thermostat and the sensor right near it because if the trouble code that directed me to why the engine was idling rough, surging and temp gauge fluctuated. After two hours of the battery being disconnected and work completed, the engine was started. naturally it was rough at first. problem is engine light back on with same code telling me its the thermostat or sensor. further the engine still idles rough from time to time at a stop light. The temp gage is dead nuts 212 area and does not move anymore. How long does it take the computer to relearn it's paramters that were reset?
 

·
Registered
2004 gmc envoy_slt
Joined
·
102 Posts
What code is it? P0128?
 

·
Registered
2005 chevy trailblazer_lt
Joined
·
46 Posts
Discussion Starter · #4 ·
hey roadie....the TB is spotless after cleaning prior to this post. would the computer throw out misc trouble codes while it's relearning it's paramters. I pulled two codes out p0017 crankshaft position and there was one for PCM under the ABS codes which was c0055...i cleared the codes out and am driving around to wait for the bad idle to happed.....there has been about 3 hours of driving since the battery was reconnected.....
 

·
Registered
2005 chevy trailblazer_lt
Joined
·
46 Posts
Discussion Starter · #5 ·
cam solenoid acutuator

well after multiple p0017 codes after resetting again again and again. i replaced to cam and crank sensor (because the cheapest) and still no effect on rough idle/stalling. I took the plunge on looking at the cam actuator, and after moving the power steering pump out of the way...i seen to much delight, one of the protectives screen(3 total) had broken off and some of it was jammed into the solenoid. GM charged 95.00 for a new one and so far no idle issues. should have just look at this first and saved 50 bucks!
 
1 - 5 of 5 Posts
Top