Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 4 of 4 Posts

·
Registered
2005 chevy trailblazer_ls
Joined
·
274 Posts
Discussion Starter · #1 · (Edited)
Ok. so I am headed back from Wal-mart and i have my window down. All of a sudden i get a very annoying tapping/clicking noise . I slow the trailblazer down and then punch the gas a bit. I notice that the noise gets VERY loud when the accelerator is given more gas. So i drive home. pop the hood and notice that there is a very faint oil strip running from where you put the oil in all the way to the belt. Needs to say there is some oil on the belt. Not sure if this is causing it or not. I'm very curious about the oil of why this would be. And Also what the problem might be. (I use Mobil 1 5w-30 Truck & SUV). I have checked the oil level and it is perfect. anyone else have a similar issue? I don't want to drive my trailblazer until i know what is going on. My dad is coming over tonight to look it over and see if he can help me. The miles on it are 101,523 .
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
274 Posts
Discussion Starter · #2 ·
My dad and i took apart the trailblazer and found out that the WATERPUMP is VERY LOOSE and that is making the noise and explains all of the above issues. If someone ever has a similar problem this forum will help them out :thumbsup:
 

·
Registered
2002 olds bravada
Joined
·
2,369 Posts
glad to know its fixed! good thing you caught it before it did some serious damage! :thumbsup:
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top