Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 11 of 11 Posts

·
Registered
2002 chevy trailblazer_lt
Joined
·
297 Posts
Discussion Starter · #1 ·
all of a sudden the signal arrows in my dash for the right started blinking fast, when i went to the rear and checked my tail light signal i noticed that it was blinking but really dim. i opened up the tailight and noticed that there was a clear grease where the signal bulb goes is that supposed to be there? if it is then what could be the problem. the head light signal works just fine.
 

·
Banned
2003 gmc envoy_slt
Joined
·
7,190 Posts
Yup, the dielectric grease is supposed to be there. The top light is the turn signal light (At least in the Envoy). Is that the one that was blinking dimly? If not, it could be the circuit board. But you should test the bulbs first to eliminate that as a problem.
 

·
Registered
Joined
·
8,781 Posts
Hyperflash, as it is known, is activated when one of your bulbs goes bad. The turn lamp is a dual filament. If it is blinking dim, one of the filaments has burnt up and you need to replace the lamp. Lamp #3157

LOL yeah I know this... just wanted to make sure that if he swapped the bulb with another one the problem would go away.. hence that the bulb is at fault and thus needing a new one ;)
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
297 Posts
Discussion Starter · #8 ·
okay so i took off both rear tail lights and took the turn signal bulb out of the right side and put it into the left side and the bulb worked so its not the bulb, then i checked the fuses and they were all fine. the thing is only the rear right turn signal is not working the brake and reverse are fine. is it the circuit board? if so does it matter what side circuit board i get? because theres a salvage yard here selling the left side only. thanks in advance for any advice i get.
 

·
Registered
2009 chevy
Joined
·
6,431 Posts
okay so i took off both rear tail lights and took the turn signal bulb out of the right side and put it into the left side and the bulb worked so its not the bulb, then i checked the fuses and they were all fine. the thing is only the rear right turn signal is not working the brake and reverse are fine. is it the circuit board? if so does it matter what side circuit board i get? because theres a salvage yard here selling the left side only. thanks in advance for any advice i get.
It does sound like the circuit board.
I have read here, that people have swapped the right side, left side to test a board; but that does not mean they are the same.

Pull both boards and check the part numbers.
 
1 - 11 of 11 Posts
Top