Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 6 of 6 Posts

·
Registered
2005 gmc envoy_denali_xl
Joined
·
14 Posts
Discussion Starter · #1 ·
I have a 05 Denali and have had for about a week. I bought it used with 70k fully expecting to have to replace a few wear items. Looks like front struts and mounts are first based on what I have driven so far.

When I hit a decent sized bump or ridge in the road there is no noise just a front end that bounces before it relaxes again so I know the struts are bad. I am going to replace them with bilstein and new strut mounts well I am at it.

Now when I hit a smaller bump or ridge at slower speed I get a rattle and slight vibration. I am thinking the struts could be to blame and or the end links up front based on what I have read.

Is there anything else this could be before I start diagnosing and throwing more parts at it?

Thanks in advance...
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
At 70K those are suspect. A Denali probably isn't being bashed about offroad, but at 70K I needed new upper control arm bushings, tie rod ends, and anti-sway bar bushings. Getting it on a lift and pulling the wheel back and forth will show up loose control arm and tie rod issues.
 

·
Registered
2005 gmc envoy_denali_xl
Joined
·
14 Posts
Discussion Starter · #3 ·
Well it sounds like I am heading in the right direction then....Thanks...Anything else I should check out well I have things apart?

I will probably swap out sway bar bushings and go with something poly for the added benefit but I don't want to get into the control arm bushings and all that unless I have to. I just got done replacing every bushing on my GTO and that is not a fun couple days of work....
 

·
Banned
2003 gmc envoy_slt
Joined
·
7,190 Posts
There are different sizes of sway bars. You'll be ahead of the game if you measure yours before you try buying new ones.:m2: I've seen the polys with grease zerts at Auto Zone. Unfortunately they didn't list them for the big sway bar on my '03.
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
4 Posts
I have a 05 Denali and have had for about a week. I bought it used with 70k fully expecting to have to replace a few wear items. Looks like front struts and mounts are first based on what I have driven so far.

When I hit a decent sized bump or ridge in the road there is no noise just a front end that bounces before it relaxes again so I know the struts are bad. I am going to replace them with bilstein and new strut mounts well I am at it.

Now when I hit a smaller bump or ridge at slower speed I get a rattle and slight vibration. I am thinking the struts could be to blame and or the end links up front based on what I have read.

Is there anything else this could be before I start diagnosing and throwing more parts at it?

Thanks in advance...
My trailblazer has 78K and has the vibrations you describe that you can hear on slight bumps. When I lightly bounce it you can feel the vibration on the strut when I bounce it hard it goes away. Was the strut the problem for you? Anyone else have this problem? Can anyone give me the steps to replace it if it is the problem?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top