Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 8 of 8 Posts

·
Registered
2009
Joined
·
349 Posts
Discussion Starter · #1 ·
When I turned my AC on today I started getting power surges. Especially at idle. I know typically the RPMs will adjust slightly when turning the AC on and then level out, but this is a lot worse.

When I'm coming to a stop the RPMs will jump up about 500 or so RPM which was scary at first as I almost rear ended the guy in front of me. It will keep doing this until I turn the AC off at which time the RPMs do a huge dip down and then level back up.

First thought is the alternator. Wondering if there are any tests I can run to determine what the issue might be.

Oh....yes, I know I have a post right below this on how I installed my amp today :):) Don't think it's related...just a coincidence. I had wired the amp up last night and did not hook anything up. This happened on the way home from work today...sub was not even hooked up.

To test, I put the old battery terminal back in (had the post adapter in for the amp) and completely unhooked the amp....same thing. Also, battery meter says I have a full charge. And....I hooked up the amp and ran the sub directly off the battery without the car running and it was fine. The battery is 2 years old.

Thanks,

DAVE
 

·
Registered
2007 chevy trailblazer_ls
Joined
·
183 Posts
It sounds like that your AC compressor may be in the process seizing. The engine is trying not to stall when the compressor turns on. :m2:
 

·
Registered
2003 trailblazer_lt
Joined
·
9,856 Posts
Oh....yes, I know I have a post right below this on how I installed my amp today :):) Don't think it's related...just a coincidence.
Classic problem after the battery has been disconnected while installing audio gear....this can be fixed by cleaning the throttle body and resetting the pcm. There is a how to in the articles section.
 
1 - 8 of 8 Posts
Top