Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 5 of 5 Posts

·
Registered
2008 chevy trailblazer_ss_3ss
Joined
·
2 Posts
Discussion Starter #1
Having problems with 3rd gear while under extreme acceleration. While under normal driving, you don't feel anything wrong, but while cruising between 30 and 40 mph, I stump on gas, it will downshift to second for power range, then slips into 3rd (raising RPM's without forward motion).

1. My SS specialist recommends trans change for total of $3,000 (GM 3
yr warranty with this option)
2. I've found tricked/improved trans on ebay for $1,800 with option to
purchase 2, 3, or 4 yr warranty) at lower than option #1.
3. Friends into performance and my research of on line trouble shoots
recommend change solenoids 2-3 or 3-4 or both which are priced at
approx. $40. on ebay as well.

Can anyone help me out ? I take care of my SS like a lady and this trans problem has come as a big surprise and I am very upset at GM.

Sincerely,
Jose
NJ: bonk:
 

·
Registered
2007 chevy trailblazer_ss_3ss
Joined
·
2 Posts
SS trans problems

How many miles on it?

Has the trans been serviced? (Filter, fluid)

Check the dipstick and wipe the fluid on a white paper towel or piece of paper.

Is it Red, Red with a little grey? Brown? etc...

Does it smell burnt?
 

·
Registered
2008 chevy trailblazer_ss_3ss
Joined
·
2 Posts
Discussion Starter #3
Truck just reached 41,000 miles during my recent road trip to Myrtle Beach, S.C. The trans has not been serviced, I was waiting to reach 50,000 miles before current problem started. Now I was worried that a complete trans service might make 3 gear symptom worst. Fluid is regularly checked as I baby all my cars, and still reddish in color. It don't smell burnt.
Thanks for interest and response. All help is appreciated.
 

·
Registered
2009 gmc envoy_slt
Joined
·
59 Posts
Try a PCM tune first mate. I'm convinced some of our trans were programmed defective. Mine did the same exact thing and a program from PCM of NC fixed all issue. Good luck mate

Sent from my XT1254 using Tapatalk
 
1 - 5 of 5 Posts
Top