Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 3 of 3 Posts

·
Registered
2002 chevy trailblazer_lt
Joined
·
1 Posts
Discussion Starter #1
I have an 02 TB, w/ 95k, I've owned since 2004 when she only had 15k,it has always seemed to have a soft / spongy ride, since the day I drove it off the lot.
Now it seems to have gotten worse, especially when driving over bumps at higher speeds (60 mph) ,seems to sway a lot now.
I've only replaced the outter tie rods, everything else is original. Has anybody else had theses same issues ( swaying, spongy ride ) And what did you do to resolve it.

I'm going to start off by replacing the oem rear shocks.:rotfl:
 

·
Registered
2007 chevy trailblazer_ss_3ss
Joined
·
3,118 Posts
I have an 02 TB, w/ 95k, I've owned since 2004 when she only had 15k,it has always seemed to have a soft / spongy ride, since the day I drove it off the lot.
Now it seems to have gotten worse, especially when driving over bumps at higher speeds (60 mph) ,seems to sway a lot now.
I've only replaced the outter tie rods, everything else is original. Has anybody else had theses same issues ( swaying, spongy ride ) And what did you do to resolve it.

I'm going to start off by replacing the oem rear shocks.:rotfl:
a set of HD Bilstien front struts and some new rear gas shocks will help.
Add a lift to it while your at it..
 

·
Registered
2002 chevy trailblazer_ls
Joined
·
122 Posts
Hey Joe,

I just did that to my '02 TB. I bought KYB complete strut assemblies and rear KYB shocks. I kept the springs. Truck rides like new.
 
1 - 3 of 3 Posts
Top