Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Had problems with shifting,replaced shift cable (not a lot of fun), still have issues with shifting into park, dash says reverse,but still in neutral,have to go under and move into park, any ideas?
 

·
Registered
Joined
·
33 Posts
Had problems with shifting,replaced shift cable (not a lot of fun), still have issues with shifting into park, dash says reverse,but still in neutral,have to go under and move into park, any ideas?
Unhook the cable from the trans, put the trans is park, then put the shifter in park. Hook it back up.
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
16 Posts
To me it sounds like the cable is either not installed correctly or is the wrong fit / length for your vehicle.

I have never changed the complete shifter cable on my O4 Trailblazer, but have replace the plastic / nylon grommets that snap on to the shifter levers, both on the transmission and in the interior console. The aftermarket grommets do not hold up well and seem to deteriorate after a few years.
 

·
Registered
Joined
·
33 Posts
To me it sounds like the cable is either not installed correctly or is the wrong fit / length for your vehicle.

I have never changed the complete shifter cable on my O4 Trailblazer, but have replace the plastic / nylon grommets that snap on to the shifter levers, both on the transmission and in the interior console. The aftermarket grommets do not hold up well and seem to deteriorate after a few years.
I fixed mine by taking two 6 mm nuts with shoulders, a 6mm bolt and double nutted the nuts on both sides of the bolt leaving enough play for it to move and it works fine. Never break again. I don't have a picture but it looks good and works good.
 
1 - 4 of 4 Posts
Top