Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 14 of 14 Posts

·
Registered
2007 gmc envoy_denali
Joined
·
54 Posts
Discussion Starter #1
Hey guys, small issue with my 07 Denali recently, for the past couple months my Service Stabilitrak light comes on when i start my car, but then goes away when i shut it off. It will stay off for a few days sometimes but sometimes it stays off for a week or 2. Anyone else have an issue with it before? I would take it to the shop, but the light has never stayed on after i shut it off. Also, if im stopped at a stoplight, everynow and then it feels like someone tapped me from behind, like it lunges forward few inches. But i never lifted my foot off the brakes, the light is not active when it does this. Could they be tied together? Any help wou;d be help to me, thanks.
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
Don't most warning lights go out when you shut the vehicle off? :confused:

I'd take it to a shop, but not only dealers can have high end scan tools that can talk to the Stabilitrac system.

On the other issue, we had a long thread about the possible causes. In my case and some others, the bump feeling went away when I greased the end of the driveshaft where it goes into the transfer case tailpiece.

http://forums.trailvoy.com/showthread.php?t=7177
 

·
Registered
2007 gmc envoy_denali
Joined
·
54 Posts
Discussion Starter #3
Don't most warning lights go out when you shut the vehicle off? :confused:

I'd take it to a shop, but not only dealers can have high end scan tools that can talk to the Stabilitrac system.

On the other issue, we had a long thread about the possible causes. In my case and some others, the bump feeling went away when I greased the end of the driveshaft where it goes into the transfer case tailpiece.

http://forums.trailvoy.com/showthread.php?t=7177
yes it goes off when the vehicle is shut off, sorry, dumb moment, but it will not come back on for a few days or maybe weeks. So if i went to the shop, it will not come back on for at least 15 to 20 starts, maybe more.

The end of the transmission tailpiece? mine is 2wd, no transfer case
 

·
Registered
2006 chevy trailblazer_lt
Joined
·
116 Posts
I've had issues with the Service Stabilitrack light coming on but I found that it only happens when I shut the car off and the steering wheel isn't straight or nearly straight. It will come on during the next start up and goes away when I turn the car off with the wheel straight. It made it seem as though it was happening intermittently because sometimes I would leave the steering wheel straight and sometimes I wouldn't. See if that is what is happening to yours.
 

·
Registered
2007 gmc envoy_denali
Joined
·
54 Posts
Discussion Starter #6
Never thought to use my Onstar while it was on, and ill check into my steering wheel. thanks again guys
 

·
Premium Member
2008 gmc envoy_sle
Joined
·
224 Posts
There was a TSB issued about it:
INTERMITTENT STABILITRAK SERVICE/INDICATOR LIGHT ON, SERVICE STABILITRAK MESSAGE DISPLAYED, EBCM DTC C0244 SET. *KB
Bulletin Number: 1750177

From this thread:
http://forums.trailvoy.com/showthread.php?t=33384&highlight=stabilitrak+light

Mine was doing the exact same thing- I took it in under warranty and gave them that bulletin. They reprogrammed the stabilitrak module.
 

·
Registered
2007 isuzu ascender
Joined
·
201 Posts
I have this same exact issue and the dealership found that it was a faulty PCM (Computer) from the factory. I take my vehicle Tuesday for the new PCM.
 

·
Registered
2008 chevy trailblazer_lt
Joined
·
13 Posts
Service Stabilitrak Lite

Mine was coming on intermittently for several months. I took the advice I got from this website, and when the lite came on, I drove into the dealer and asked them to put the scanner on while the lite was on. They looked at me like I was from outer space, and tried to tell me to make an appointment. I asked them to simply do the scan and then we would make an appointment. They did that, traced the problem to the steering wheel sensor, and told me to come back another day to have it replaced. When I did come back the tech said I did the right thing, because to try and trace the problem when the lite was not on was a bitch. Thank the Lord I had Xtended warranty.
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
138 Posts
I have this problem sometimes too. My scanner doesn't show anything, besides that I can delete the problem.

What Sensor is it?
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
1 Posts
@ 239mike, I have a 2006 chevy TB, bought it brand new and mine has been doing the exact same thing since I bought it. At first it started off intermittently with the lights coming on, I'd shut the truck off start it back kup and it would be gone. I took it into the dealership while it was still under warranty several times but of course the lights would never come on, now 6 years later still dealing with the lights and no warranty. Took it back to the dealership once and then another shop to no avail! Very frustrating! :duh: In regards to the bumping sensation, I feel that too and did brand new, except now it feels/sounds like someone threw a baseball directly underneath my truck. I'm glad I found this website and thread and that I'm not the only one who's experienced this problem. Still not quite sure what the thumping noise is....why can't things just be simple, I miss my old chevy truck!
 

·
Registered
2007 chevy trailblazer_ls
Joined
·
2 Posts
I have this same exact issue and the dealership found that it was a faulty PCM (Computer) from the factory. I take my vehicle Tuesday for the new PCM.
How much we're the repairs. I'm having the same problem.. Thanks!
07' Chevy Trailblazer.
 
1 - 14 of 14 Posts
Top