Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 8 of 8 Posts

·
Registered
2002 chevy trailblazer_lt_ext
Joined
·
295 Posts
Discussion Starter #1
O.k., lets start with goodmorning.. "SMILE". I've read alot of forums about simular problems with the service light for the 4wd comming on and the selector switch is black, no lights on, I've tryed everything from pulling fuses which sometimes works to unplugging the battery for several hours. The whole system works fine as long as it's above 8 deg. C., from 2 hi all the wat to 4 low, anything below temperature is a no go. The sevice 4wd light comes on and nothing works. If I drive around for awhile with heat on, turn off the engine for 10 to 15 min., restart, the service light is off and eveything works fine. Could this be caused by a failty TCCM that freaks out when it's cold or do you think it could be something different? When I asked GM about a new down load to the TCCM, well it could be " I think he said encoder", the piece that bolts to the side of the transfer case. This part he said is over a "G" note. But they would have to do a scan first, an extra 65.00$.

Thanks
 

·
Registered
2002 chevy trailblazer_lt_ext
Joined
·
295 Posts
Discussion Starter #2
forgot to mention, on start-up the selector switch dose have lights that flash in it.
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
Could you add a bit of detail about the lights flashing? Do they ALL flash like a lamp test, then go out, leaving the 2WD as the only light on? And is the 2WD steady, not flashing?

Are you moving the mode selector switch at all from 2WD, or are these observations with it in 2WD only?

What happens when you move the switch to A4WD or 4HI? What flashes and what stays steady?

For now, I'm going to guess a bad TCCM that MIGHT be improved by a dealer reflash. Some 2002 TCCMs just die and quit working. Others don't wake up right away on ignition on, and those are the ones that can be improved. The "Service 4WD" on the dash does NOT come from the TCCM directly - it comes from the PCM if it fails to communicate to the TCCM.

Unless you have a flashing light on the mode selector switch when you go to A4WD or 4HI, I don't see how it can be an encoder motor failure. I think they're guessing, but unless you pay them for a diagnosis, they're not obligated to give you an accurate one.

Can you find a local buddy to swap TCCMs with for an experiment?
 

·
Registered
2002 chevy trailblazer_lt_ext
Joined
·
295 Posts
Discussion Starter #4
no, there is no lights on at all in the selector switch, they all come on for a brief second on stat-up then they all go out and stay out. But only when it's cold out, once the sun comes out and warms up the truck and I start her up it works fine or I drive for awhile stop and go the store or something when I come back and restart it works.

I wish I had a buddy or two who had a chev, only a ford. My closest to buddy with what I need is the junk yard.. and he charges.
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
997 Posts
I think Roadie is right. With your symptoms and the fact you own a 2002 means it is almost always a new TCCM that is required.

See if you can get a used TCCM from an 03 and up from your junk yard buddy. (If he doesn't have one, they can usually network with other yards around the country.) It will be cheaper than a dealer reflash and is almost certainly guaranteed to work for you, versus the reflash which has about a 10% chance of working.

Good luck and let us know what happens.
 

·
Registered
2002 chevy trailblazer_lt_ext
Joined
·
295 Posts
Discussion Starter #6
Thanks, I'll give the scapper a call and hopefully I can pick one up by the end of next week. Soon as I get one and try it out I will let you know if that was it.

Thank again
 

·
Registered
2002 chevy trailblazer_lt_ext
Joined
·
295 Posts
Discussion Starter #7
Fixed it!!

Bought a TCCM from a scrap dealer about 1/2 hour from my house for $100.00. Not bad , cheaper for me than E-Bay. I even had the chance to try it before I bought it. It came from a 04 Envoy. So far works like a charm. Good find and the money well spent.

Thanks for all the help and info, TrailVoy make alot of little and not so little tasks alot easyer.
 

·
Registered
2002 chevy trailblazer_lt_ext
Joined
·
295 Posts
Discussion Starter #8
For those of you in and about the Montreal area, this scaper seems to have a fair inventory on 02+ parts.

R T A Pièces d'Autos Usagées inc.
11250 Boul Saint-Jean-Baptiste
Montréal, QC
H1B 4B4
(514) 648-2050

There is another in St-Hubert that seems pritty good too.

Auto Pièces PAT inc.
1140 rue Soucy
Saint-Hubert, Québec
J4T 1A3

450-462-2220
Saint-Hubert 450-656-1612
Montreal 514-861-0378
Toll free 1-800-361-3720
Fax 450-656-7760

Business hours
Mon-Fri: 8:00am to 5:30pm
Saturday: 8:00am to 2:00pm
Sunday: Closed

...or contact us by email at:
[email protected]
 
1 - 8 of 8 Posts
Top