Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 2 of 2 Posts

·
Registered
chevy trailblazer_ss_1ss
Joined
·
13 Posts
Discussion Starter #1
:crazy:My 2006 saab 9-7x 5.3l is doing all kinds of strande things. Cold start produces a sharp knock in bottom end, pinning under accleration and uses oil. It only has 75000 km on it. Any thoughts?
 

·
Registered
2006 chevy trailblazer_lt
Joined
·
721 Posts
I have some general thoughts.

It sounds as though you have three separate and largely unrelated problems.

1. Loud knock from bottom end on cold start.

2. Pinging

3. Using oil

The loud knock sounds like bearings. How's your oil pressure--not from the gauge, but ACTUAL oil pressure. If it is low, the bearings may be (prematurely) worn.

Pinging is a compression and/or timing issue, or both. Timing is a PCM issue, but this is an unlikely cause. Compression would be from a buildup of deposits, and a treatment of Seafoam or similar might blow away enough carbon to eliminate the pinging. The deposits could be from excess oil burning, so this might be related to problem #3.

Oil burning is a well documented issue with this motor. Typically it is caused by either valve cover drain holes that have gotten plugged, or a lifter or three that are bleeding too much oil, overwhelming the valve seals. Do a search and you'll find the comprehensive thread. I don't have the link to that thread on this computer.

Is your truck still under warranty? If so, take it in.

Just my thoughts.
 
1 - 2 of 2 Posts
Top