Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 5 of 5 Posts

·
Registered
2004 chevy trailblazer_lt
Joined
·
6 Posts
Discussion Starter · #1 · (Edited)
Hello all im kind of new to the forum so sorry if i do something wrong.
But i have done countless research on this and cant seem to find an answer :worried:
I have a 2004 chevy trailblazer lt 6 cyl
So when i start the truck it seems to rev up to around 1300 rpm
and as i let it warmup it idles down to around 600
but if i dnt let it warm up and just take off the rpm gauge reads at around 2000 rpm
but it sounds as if it were at around 4000 and the truck doesnt really move im guessing because its still in 1st shift? not sure
as well if i leave it o for a while in park the rpm will start to decrease and itll rev up to 1200 on its own and back down to almost zero til it turns off eventually, but not long after i had found that the gas filter was leaking so in replaced it the issue is still there it just doesnt turn off anymore.
sorry its so long but i really have no clue as to whats going on or where to start looking. Thanks in dvance for all help!:)
 

·
Banned
2004 gmc envoy_sle_xl
Joined
·
1,239 Posts
The first thing to do (and do this every 10 - 15K miles) is clean the throttle body. Do a search on Throttle Body Cleaning, there are several write-ups for the procedure.. Make sure to reset the PCM (computer) by disconnecting the battery or pulling the PCM fuses (#10 & 28 in the underhood fuse panel) for at least 30 minutes. This will allow the PCM to relearn with the newly cleaned TB.
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
6 Posts
Discussion Starter · #3 · (Edited)
I actually cleaned the throttle body about a month ago and it just fixed the rpm from going up and down it still started at 1300 though
But up until maybe a couple days back is when i noticed it again
I also added some seafoam cleaner into the gas tank to se if that would help
All it did was fix the gas wasting problem not the rpm
 

·
Banned
2004 gmc envoy_sle_xl
Joined
·
1,239 Posts
It is normal for the engine to run somewhat above 1000 RPM on a cold start, and it will idle down in short amount of time. I don't know what could be causing it to go to 2000 RPM. And as far as sounding like it is going at 4000, is it possible you are hearing a bad fan clutch?
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
6 Posts
Discussion Starter · #5 ·
I have read before that thatsmiqht be what im hearing but i quee i wont kno until i try it
But still what could be causing the rpm to just qo down to about 300 then automatically rev back up to 1300 n just keep doing that until it evwntually turns off?
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top