Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 8 of 8 Posts

·
Registered
2008 chevy trailblazer_lt
Joined
·
33 Posts
Discussion Starter · #1 ·
I'm having a problem with the ambient air sensor in my 2008 TB.

I"ve just had the sensor replaced by the dealer, but the problem persists.

The issue is the the temperature which shows up on the climate control read-out is about 10-15 degrees too high. Sometimes it will stick at a temp 10-15 degrees lower than actual.

I read about resetting the sensor by pressing the "mode, front defrost and rear defrost" buttons all at the same time. My control doesn't have a "mode" button, although it does have an A/C control button.

I tried that, but it didn't seem to change anything.

Anyone have any info on resetting the later cars with the auto climate control? Thanks. :thx
 

·
Registered
2002 olds bravada
Joined
·
2,369 Posts
The Reset procedure is holding the "DEFROST" "REAR DEFROST" and the button that changes where the air comes out of (face, feet, etc).
 

·
Registered
2003 gmc envoy_slt
Joined
·
357 Posts
Your Owners Manual on page 3-24 explains what the Mode button does and it is located just below the Auto button on the Auto A/C models. And, yes, pushing the Defrost, Rear Defrost, and Mode buttons at the same time will reset the ambient temperature sensor.

C.B.
 

·
Registered
2008 chevy trailblazer_lt
Joined
·
33 Posts
Discussion Starter · #4 ·
resetting temp sensor

First, thanks to those that responded so quickly.

Second, my owner's manual doesn't show how to reset the temp, only a general description of the way the temps are displayed.

Lastly, I used the method described and it did "blink" and change the reading, but it still seems to be reading about 10-12 degrees high. I'm going to let it go for a couple of days to see if it evens out at all.

Thanks again guys.

;)
 

·
Registered
2002 gmc envoy_slt
Joined
·
3 Posts
First timer, here. 2002 SLT with auto climate. The ambient temp has been stuck on 50F for about 3 weeks; I'm in Chicago, so I know that's not right. Just saw this thread and tried the reset. It changed, but now it's stuck on -39F.

Any thoughts?
 

·
Registered
2003 gmc envoy_slt
Joined
·
357 Posts
Yes. Try again and a third time if necessary. If it won't reset with engine off, try it with engine on. If it just won't reset, replace the temperature sensor which is cheap and easy. Do a search on ambient temperature sensor for instructions and pictures.

C.B.
 

·
Registered
2002 chevy envoy_slt
Joined
·
1 Posts
02 Envoy new ambient temp sensor and tried reset

Hello everyone, I read all your recommendations on the temperature sensor. Mine usually starts out at a correct temperature and the would go to 50 degrees and stay on it....It used to count down from a higher temp. I went ahead and replaced the sensor and then tried the reset twice... I will have to check to see if there is enough A/C Freon in it, but the temp now seems to stick around 95 or 94.....any other suggestions? Not blowing cold air out yet, but it used to when the outside temp was correct. Worked shortly about two weeks ago, but the temp issue has been going on for a year now.
 

·
Registered
Joined
·
1 Posts
I replaced the ambient censor with a genuine gm part.I did everything you suggested with the three control buttons.It starts at -39 and goes through the motion and always ended up at 50 degrees.I even made sure the code the cleared.Any more suggestions what else could be the problem?
 
1 - 8 of 8 Posts
Top