Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi, I have a 2002 Chevy Trailblazer LS that I bought a couple weeks ago and have been working on replacing the radio but have had no luck. The radio that was in the car when I bought it was an after market Kenwood KDC-255U, but my uncle has an old radio from a friend's truck that's a Planet Audio P9752B, which is fully functional. After deciding to replace the Kenwood radio with the Planet Audio one I took apart the dash and discovered that the wiring job that had been done to put in the Kenwood radio was abysmal, to the point that one of the speakers in the car had not even been wired(I think he mistook that speakers wires for wires from something else). Now that I've begun the transplant I've wired the Planet Audio radio to the trailblazer in the same manner as the old radio and it isn't giving me any indication it has power, even after me fiddling with the way it was wired for two hours. I then gave up and tried to put the old radio back in and after wiring it the same way that it was it gave me no response. I'm almost certain it's not a blown fuse because my multimeter indicates that the power wire from the trailblazer is giving power, the radio's just aren't turning on. I've done extensive research into both radio's and have come to my wits end, though I'm certain it's something I'm doing on my part. Do you guys have any ideas on what I could be doing wrong?
 
1 - 1 of 1 Posts
Top