Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 7 of 7 Posts

·
Registered
2005 gmc envoy_sle_xl
Joined
·
1,029 Posts
Discussion Starter #1
:coffeeI am going to install a Viper 571XV remote start in my girlfriends 2007 TB. I have been reading about how to do this using the GM9 harness and CANbus wire on the ODBC2 connector. I seem to have all the info I need to getr started except for what type of bypass to use. Which one do I get? Most installers around town use idatalink ADS. I wanted to use a Fortin INT-SL but the Fortin GM-SL will work to as I don't have the two way data link to use anyway. Any suggestions on what to use as a bypass module?:thx
 

·
Registered
2005 gmc envoy_sle_xl
Joined
·
1,029 Posts
Discussion Starter #3
I was under the impression that the class 2 serial data wire was used through 08, do you have any info on this?

:thx

http://www.gmtcny.com/serial data.html

All OBD-II compliant DLCs are required to provide a power supply, B+ at all times, to Pin 16.This positive supply is used to power the scan tool. All DLCs supply a power ground at Pin 4 and a clean signal ground at Pin 5. The Class 2serial data circuit is provided at pin 2 of the DLC.
I believe Pin 2 is a purple wire.
 

·
Registered
2005 gmc envoy_sle_xl
Joined
·
1,029 Posts
Discussion Starter #5
Thanks for the link....I thought you were referring to pins 6 (High Speed GMLAN serial data +) and 14 (High Speed GMLAN serial data -)
Yeah I think this is basically Ethernet. Does GM have this now in their vehicles? I read an article a few months back that said this will take a while to come out.

I don't want to get off track but my original question was refering to the actual Remote Start + Bypass module. I would like to know if anyone has used a Viper remote start with a Fortin or idatalink or something else to that effect. I would like to take advantage of any serial link that may exist between the Bypass module and Remote Start
 

·
Registered
2005 gmc envoy_sle_xl
Joined
·
1,029 Posts
Discussion Starter #6
Viper 571XV Remote Start is Now Installed!!

This has been bumped
 

·
Registered
2005 gmc envoy_sle_xl
Joined
·
1,029 Posts
Discussion Starter #7
Viper 571XV Remote Start is Now Installed!!

Hi guys,

I now have a Viper 571XV with a XK01 installed. Everything seems to work ok except for a few loose ends which I hope someone could help with. Here is the wiring diagram I used. I got this from another gent who hooked up a 2005 Silverado. I have modified it to my preference.

All connections were soldered except for the brake and ODBII wires. I used t-taps on these wires.

Viper 571XV:

H1/1 – Orange - NC
H1/2 – White - NC
H1/3 – White/Blue – NC
H1/4 – Black/White – NC
H1/5 – No Wire - NC
H1/6 – Blue – NC
H1/7 – No Wire - NC
H1/8 – Black – Ground to chassis. I soldered together this wire with the XK01 pin 10 ground and H3/5 neutral safety wires and screwed to sheet metal.
H1/9 – No Wire - NC
H1/10 – Brown – NC
H1/11 – Red – 12v Constant Red ignition wire (column harness)
H1/12 – Red/White – NC

H2/1-4 None of these wires needed/connected.

H3/1 – Blue/White – XK01 brown wire
H3/2 – Gray – Hood Pin Switch (Always Connect!)
H3/3 – Brown – White wire at brake switch (Always Connect!)
H3/4 – Violet/White – NC (set 571XV to voltage sense)
H3/5 – Black/White – Neutral safety grounded with other grounds (is this ok??) Does XK01 pickup neutral safety through ODBII?

H4/1 – Green – XK01 Green Wire
H4/2 – No Wire
H4/3 – Blue – XK01 Blue Wire


XK01:

1 Brown – Viper H3/1
2 Green – Viper H4/1 Green
3 Blue – Viper H4/3 Blue
4 Violet/White – NC
5 Violet – OBDII pin 2 Violet
6 Pink/White – NC
7 Pink – NC
8 Orange – NC
9 Red – Soldered to 12v constant red ignition wire (column harness)
10 Black – Soldered together with other grounds and screwed to chassis


All is well except for a few questions regarding my setup above.

1. Does the neutral safety need to be connected another way? Not sure if just grounding it is a safe thing to do.

2. When the trailblazer is started I get no parking lights on. Doesn't the XK01 turn these on? The Xpresskit.com website says the XK01 controls the parking lamps but it doesn't appear to be doing so. The Silverado gent hooked his Viper H1/2 to the parking lamp - negative wire behind the switch. Kind of confused here.

3. What do I connect to the Brown pin 1 on the XK01? The Silverado gent has the Viper H3/1 BLUE/WHITE (-) 200 mA 2ND STATUS/REAR DEFOGGER - LATCHED/PULSED connected. This is how I have it and it seems to work but I am unsure.


I would appreciate any comments.

thanks
 
1 - 7 of 7 Posts
Top