Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 20 of 20 Posts

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a question... anyone else ever experience the problem with their rear windshield wiper not reseating after being turned off? I can use it once, and then when I turn it off the guide below the wiper does not slide to the outside of the cradle but rather hits it dead center and rests in that position. Perched on top of the cradle. This, of course, is not the reset position so I can not use the wiper again until I stop the truck, get out, walk to the rear and pull the wiper blade out so it will fall into position. It is annoying. Any advice? Thank you.
 

·
Registered
2006 chevy trailblazer_lt
Joined
·
5 Posts
mine also

I just checked my rear window wiper.
It's not sitting in the pocket after use.
Should it?
 

·
Registered
2002 chevy trailblazer_ls
Joined
·
2,461 Posts

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
5 Posts
Discussion Starter · #4 ·

·
Registered
2002 chevy trailblazer_ls
Joined
·
2,461 Posts
Thank you very much.
May I correctly assume that this 2007 redesigned rear wiper can be installed on the 2005 model?
100% interchangeable :thumbsup: I have one on my 02. If you replace the wiper rest (should come with the kit), that will require you taking off the inside paneling of the hatch to get to the screws. Not a big deal to do, otherwise you just take the old arm of and replace with the new.
 

·
Registered
2006 chevy trailblazer_lt
Joined
·
721 Posts
I bought the kit but did not replace the rest. Yet.

The old rest will work, but not perfectly. The arm does not "park" properly in the old rest.

So, as soon as it warms up I am going to replace the rest so that the arm "parks" properly.

The functionality of the new arm and blade are a huge improvement over the old design. And they look better too.
 

·
Registered
Joined
·
2 Posts
Hey Gang-

Just wanted to pass on a big THANK you to the forum... replaced the rear wiper on my '03 TrailBlazer a couple of weeks ago... works SO MUCH BETTER. Definitely go with the redesigned '07. Very easy to do and very much worth it! Thanks friends!

J
Cedar Rapids, IA
'03 TrailBlazer LS
 

·
Registered
Joined
·
7 Posts
Rear Wiper Freezes

sometimes when i turn my rear wiper on it does not work . however if i go tap it it will work sometimes . was wondering if anyone was having or has had the same issue i have a 02 TB. This stinks because i would like to use my rear wiper when i am driving in bad weather .any solution's or suggestions will be appreciated.

Thank you
 

·
Registered
2002 chevy trailblazer_ls
Joined
·
2,461 Posts
sometimes when i turn my rear wiper on it does not work . however if i go tap it it will work sometimes . was wondering if anyone was having or has had the same issue i have a 02 TB. This stinks because i would like to use my rear wiper when i am driving in bad weather .any solution's or suggestions will be appreciated.

Thank you
Mine does something like that at times. I will hear it do something but not move, if I click it one more sometimes nothing then third it usually works. Always works fine after that. Or I just hit the spray button, and that is usually all I need anyways. I don't like having it on all the time.
 

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
5 Posts
Discussion Starter · #10 ·
Thank You

To Michblaze02: You Rock Dude! You are The Man! Ordered the new 2007 wiper kit from the place you suggested. Installed per the instructions you sent. Works perfectly! Thank you so very much! I really appreciate it.
 

·
Registered
2002 chevy trailblazer_ls
Joined
·
2,461 Posts
To Michblaze02: You Rock Dude! You are The Man! Ordered the new 2007 wiper kit from the place you suggested. Installed per the instructions you sent. Works perfectly! Thank you so very much! I really appreciate it.
Awesome thanks! Glad to hear everything worked out for you :thumbsup:
 

·
Registered
Joined
·
42 Posts
Okay, the 07 arm looks slick, will get me one of them, but my rear wiper, when I first got the TB back in May 08, when you switched it on, it would go VVEEERRRYYYYYY slowly like it was stuck, and then it started to work a bit faster and then okay, I figured it was because the TB had been on a car lot for a few months not being used.

Thought no more of it.

It started running painfully slowly again this week, sometimes not reaching the other side of the wipe area, it would just stop mid-wipe and only switching it on and off, 7 ot 8 times, made it go back into rest.

Any ideas? Will the 07 mod fix this?
 

·
Registered
non_gmt360 other
Joined
·
35 Posts
I don't know if there is a secret or anything, but I've bought a *lot* of stuff from the states in the last little while, including the rear wiper kit from parts4chevys. I ask all the people I buy stuff to ship with US Postal Service.

I've yet to pay a customs charge using USPS.

YMMV though...

G
 

·
Banned
2003 gmc envoy_slt
Joined
·
7,190 Posts
Okay, the 07 arm looks slick, will get me one of them, but my rear wiper, when I first got the TB back in May 08, when you switched it on, it would go VVEEERRRYYYYYY slowly like it was stuck, and then it started to work a bit faster and then okay, I figured it was because the TB had been on a car lot for a few months not being used.

Thought no more of it.

It started running painfully slowly again this week, sometimes not reaching the other side of the wipe area, it would just stop mid-wipe and only switching it on and off, 7 ot 8 times, made it go back into rest.

Any ideas? Will the 07 mod fix this?
No. All this changes is the arm, parking ramp ( if you want) and blade.
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
5 Posts
My situation is that on my 02 Trailblazer, the other morning with frozen weather I tried turning on the rear wiper. After a click it just stopped working.
Now, whenever I turn it on, I hear the motor working but the wiper does not move at all.
What's a noob like me to do? Do I need to replace the entire wiper setup for one of those 07 setups? Is there any way I can reconnect the arm to the motor? Any other ideas?
Thanks
 

·
Banned
2003 gmc envoy_slt
Joined
·
7,190 Posts
Did you take the bolt cover off to see if the bolt is moving?
 
1 - 20 of 20 Posts
Top