Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 8 of 8 Posts

·
Registered
2005 chevy trailblazer_ls
Joined
·
331 Posts
Discussion Starter · #1 ·
My rear sway bar is knocking like crazy whenever i hit a bump. It kind of sounds like the suspension is falling apart. I believe it to be the bushings but do they make thicker poly bushings? Since the lift it does not sit where it used to which is causing the knock. There is about a 2 inch gap between the rubber bushing and the chassis. And where does everyone get their bushings from?
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
1,708 Posts
Could be he is not talking about the sway bar bushing. :confused:
 

·
Banned
2005 gmc envoy_sle
Joined
·
3,253 Posts
isint this the sway bar end links "rattling" that people talk about???,,,i guess its a common problem,{mine does it also}....the ones that most people get to replace the bad stock ones are usually MOOG.
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
331 Posts
Discussion Starter · #6 ·
Can't be reproduced withour driving

If it helps any it can not be reproduced without driving over a bumpy road. We grabbed it by the tow hook and shook the hell out of it and no noise at all. I'll take a few pics tomorrow but it seems like the sway bar is way too easy to move and that is what is hitting i believe. When I push on it it makes the noise. The stabilizer links look perfectly fine i just replaced a front one.
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
331 Posts
Discussion Starter · #7 ·
pics ot the problem

It seems like the part by the rubber bushings is hitting the top. Sorry pics aren't that great should have thought of that while it was on the lift. My friend who's a mechanic insists i need longer stabilizer links but won't listen that they don't make them. It should be ok to get an alignment right? Since they should only be touching the front.
 

Attachments

·
Registered
2005 chevy trailblazer_ls
Joined
·
331 Posts
Discussion Starter · #8 ·
Found the problem

I did not know the sway bar brackets got hooked in twice. I screwed the bracket in but did not put the lip in on the bushing after installing the lift. Hard to believe all that noise came from that little mistake. :bonk:
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top