Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Having problems with my 02 TB LTZ. The rear latch along with the rear windshield wiper will not work. When I use the remote to click unlock all 4 doors respond by unlocking (usually the rear latch as well) but its not. I also noticed that after turning off the ignition the radio turns off right away instead of staying on until opening doors..

do all of these things have a common problem? Looking for any help or advice..thanks!
 

·
Registered
2002 chevy trailblazer_ltz
Joined
·
205 Posts
when my rear door and wiper weren't working, i had to unlock the door from the inside and pull the rear interior panel off. then all i had to do was push the electrical connector back into it's socket, it had come loose, about the radio i have no idea. good luck.
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
41 Posts
The issue I have is that the wiper fluid (windex) doesn't come out from my outlet like it should. I hear it working, but then the fluid just somehow accumulates on the bottom where the rear door latches onto the car.
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
Similar to the other issues - first you have to gain access to the inside of the liftgate by taking off the panel. Then find where your washer fluid tubing is disconnected or broken inside.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top