Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 8 of 8 Posts

·
Registered
2003 chevy trailblazer_lt
Joined
·
8 Posts
Discussion Starter #1
I have a 2003 Trailblazer LT, and when I unlock the all doors the rear hatch does not unlock. What would be my first course of action?
You all have ALWAYS been a huge help in the past, so posting this question was the first thing I wanted to do...any help would be greatly appreciated!
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
Use the instructions inthe Owner's Manual to get the liftgate open, then look for broken wires in the hinge area where they flex all the time. That's the most common fault, plus corrosion/frozen water in the latch mechanism itself. Or a blown LGM fuse.

Does your rear wiper work?
 

·
Registered
2004 chevy trailblazer_ls_ext
Joined
·
57 Posts
There is a little whole in the back door from the inside and you pop the cap off and it should allow you to unlock the door manually. After that check your connections. Usually it is just loose, that has been my experience at least. Has happened twice to me. But I guess new parts could be required. Good luck!
 

·
Registered
2003 gmc envoy_slt_xl
Joined
·
3 Posts
Rear Hatch Wont Unlock Also

I have a 2003 GMC Envoy SLT, when I unlock all doors the rear hatch does not unlock. My rear window wipers doesn't work either. I'm trying to find out the name of the actual part that needs to be replaced. Would it be called rear lift gate latch, rear door lock actuator, etc.?
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
You're much more likely to have a broken wire or two inside the rubber boot at the liftgate hinge line than you are to have a broken or misadjusted latch mechanism.

But if you're curious about the exploded parts diagrams of what's inside the liftgate, just go to www.compnine.com
 

·
Registered
2007 chevy trailblazer_lt
Joined
·
13 Posts
I had the same problem along with tire monitor light flashing. Turned out to be connections on body control module under rear seat,I just undid plugs and reseated them. problem solved
 

·
Registered
2002 chevy trailblazer_ls
Joined
·
9 Posts
Roadie! Help!
I'm having a problem with my hatch lock actuator. The rear wipers would work intermittently, before I just removed the dern arm, sometimes the rear defogger would not work at all either.
I have replaced the actuator with a junkyard one and pulled the wires near the hinge for inspection, couldn't find any broken wires at all. Checked the plugs and everything else for corrosion and found all to be in good shape. Is there another thing I should be looking for?
 
1 - 8 of 8 Posts
Top