Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 2 of 2 Posts

· Registered
2009 chevy
Joined
·
6,513 Posts
The front ac speed control is a very common gm problem.
You will need a new blower motor speed control module (auto HVAV), or a blower speed resistor assembly if you have the manual HVAC.

Try a search, there is a ton of info on the site.

The rear, of course, should work from the front control, or from the rear control when the front knob is at R.
This also sounds like the blower motor speed control assembly (there is only one for auto or man systems). Or, possibly a bad blower motor.

Welcome to the site
 

· Registered
2009 chevy
Joined
·
6,513 Posts
Yes, that would be the manual system.

Yep, I hear ya, the right search word is a big help.
Try blower resistor.

The rear problem is a new one, I might look at the speed control unit, or a poor ground.

The speed control unit is mounted at the blower motor (both front and rear). You can get to the motor in front by getting under the dash and behind the glovebox. The one at the rear is behind the side panel that is behind the rear passenger door.

The rear motor speed control is a digital unit (only type used at rear), we don't have a lot of trouble with it, but it could be overheating. The motor it's self could be over heating, or the ground (it would be a black wire) might be loose.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top