Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 16 of 16 Posts

·
Registered
2006 chevy trailblazer_ss_ls
Joined
·
7 Posts
Discussion Starter · #1 ·
Hello everyone:D I have a 04 TB Ext with a 5.3L V-8. Love the truck except for one issue::mad: It has a misfire when cold or hot. CEL code PO300. Which is a random mis-fire. Truck has almost 90,000 miles and has been maintained religiously. Has new A/C delco plugs and wires,new intake manifold gasket, new fuel filter and air filter. I have cleaned the throttle body and did a BG fuel system service. Replaced ignition parts twice in last three months. Also replaced two coils even though they specd out fine. I am at wits end:(. Any help would be appreciated. Thanks in advance!
 

·
Registered
2006 chevy trailblazer_ss_ls
Joined
·
7 Posts
Discussion Starter · #3 ·
I forgot to mention that when I did the intake gaskets I did replace the cam sensor and crank sensor. I will try the map sensor. Thank you. Will keep you informed to see if that take care of problem:thx
 

·
Registered
2006 chevy trailblazer_ss_ls
Joined
·
7 Posts
Discussion Starter · #4 ·
Did map sensor. No change:hopeless I'm close to getting a match. Any ideas would be appreciated:thx
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
1,708 Posts
check the EGR valve (Exhaust Gas Recirculation Valve).
The I-6 does not use a EGR valve. OOPS, I cannot read, you have the v-8 sorry......
 

·
Registered
2007 chevy trailblazer_lt
Joined
·
228 Posts
coil packs

known problem for coil packs to short out....maybe a wire (spark plug wire) touching???

try to see which cylinder is missfiring....a scan tool will tell you....

Don
 

·
Registered
2006 chevy trailblazer_ss_ls
Joined
·
7 Posts
Discussion Starter · #9 ·
Finally the problem got worse and was easier to find. Had to replace Throttle Body Assembly and gasket. Not bad found a reman unit with lifetime warranty for $160.00 at O'Reilly Auto. Easy repair to do. My truck is back:woohoo: Thanks guys for all your advice:thx:grouphug:
 

·
Registered
2006 chevy trailblazer_ss_ls
Joined
·
7 Posts
Discussion Starter · #11 ·
After I made sure its was not a spark problem, I checked around intake and throttle body and vaccum hoses using B-12 spray with engine running. The idle changed around the throttle body. That was my problem a simple vaccum leak.
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
18 Posts
After I made sure its was not a spark problem, I checked around intake and throttle body and vaccum hoses using B-12 spray with engine running. The idle changed around the throttle body. That was my problem a simple vaccum leak.

Thank you, I'll try the same with my TB.
 

·
Registered
Joined
·
227 Posts
I've read the throttle body gaskets on the 5300's are crap, at least in the early 2000's. Apparently GM's released a "new" and "updated" gasket. Coil pack fixed the issue I had with my 5300, even though it was showing "random/multiple cylinder misfire". A code reader with real-time misfire data is invaluable.
 
1 - 16 of 16 Posts
Top