Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 4 of 4 Posts

·
Registered
2006 chevy trailblazer_ls
Joined
·
4 Posts
Discussion Starter #1
Like most post i've seen my radio is doing the same thing, working in the warm weather and only the tweeters in colder weather. I was checking all my grounds and open the fuse box cover under the driver side back seat and saw that theres a black delphi box on the fuse block. It has a what i would call a color grid one side says tan one says grey but the indicator says blue, does this have anything to do with the radio? MY door and fuel chimes are not working. I hate to buy a new radio to fine out it maybe somethin else. (i do not have the boss system) any help would be greatly apperciated.
 

·
Registered
2005 isuzu ascender
Joined
·
319 Posts
If it's like my problem, I had to replace all my OEM speakers. I had only 1 in front left working and didn't realize it until it started going in and out and I could only hear the tweeters.

If your tweeters are outputting the sound correctly then the radio must be sending the signal OK... The OEM speakers stink. All of mine failed open (using an ohm meter). I replaced them with two $20 sets, cheap but nice enough and better than new. Its an easy job to do yourself.
 

·
Registered
Joined
·
1 Posts
Like most post i've seen my radio is doing the same thing, working in the warm weather and only the tweeters in colder weather. I was checking all my grounds and open the fuse box cover under the driver side back seat and saw that theres a black delphi box on the fuse block. It has a what i would call a color grid one side says tan one says grey but the indicator says blue, does this have anything to do with the radio? MY door and fuel chimes are not working. I hate to buy a new radio to fine out it maybe somethin else. (i do not have the boss system) any help would be greatly apperciated.
did you ever find your problem, Im having same trouble.
 
1 - 4 of 4 Posts
Top