Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 20 of 24 Posts

·
Registered
2003 chevy trailblazer_lt_ext
Joined
·
321 Posts
Discussion Starter · #1 · (Edited)
Ok guys the TB is acting up and I'm not sure what it is at this point. It FEELS like hesitation/miss/jerk.
No codes (at least thrown codes), no lights, nada.
It happens in park and when driving (I believe even during acceleration though not near as noticeable/often). Fiance claims it didn't happen when in 3rd gear but would in D. Load difference on engine or a transmission problem? I don't know. I can tell you I can watch the rpms drop on the tach when it does it.

The only thing I have done is cleaned the TB (by removing it) and having the battery disconnected while doing so for 30 minutes or more. There are 68,000miles on it I do believe.

So is it transmission related or bad coil/plug issue?
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
1,113 Posts
Ok guys the TB is acting up and I'm not sure what it is at this point. It FEELS like hesitation/miss/jerk.
No codes, no lights, nada.
It happens in park and when driving (I believe even during acceleration though not near as noticeable/often). Fiance claims it didn't happen when in 3rd gear but would in D. Load difference on engine or a transmission problem? I don't know. I can tell you I can watch the rpms drop on the tach when it does it.

The only thing I have done is cleaned the TB (by removing it) and having the battery disconnected while doing so for 30 minutes or more. There are 68,000miles on it I do believe.

So is it transmission related or bad coil/plug issue?
how long ago did you clean the tb? :undecided has the issue gotten any better since the clean?
 

·
Registered
2009 chevy
Joined
·
6,431 Posts
Usually a low speed problem is fuel related, where as plugs/coils act up at higher speeds. Of course, we know they both can act up at any speed, but I use the above to chase troubles.
Using my "rule of thumb", check all fuel related items. You've cleaned the tb, try a can/bottle of injector cleaner. You might have an injector that's plugged or leaking.

Any chance there might be water in the gas? Try a different brand.
 

·
Registered
2003 chevy trailblazer_lt_ext
Joined
·
321 Posts
Discussion Starter · #4 ·
Usually a low speed problem is fuel related, where as plugs/coils act up at higher speeds. Of course, we know they both can act up at any speed, but I use the above to chase troubles.
Using my "rule of thumb", check all fuel related items. You've cleaned the tb, try a can/bottle of injector cleaner. You might have an injector that's plugged or leaking.

Any chance there might be water in the gas? Try a different brand.
I will try some seafoam tomorrow night. It didn't seem to help the problem with cleaning the TB but will definately do the injector cleaning tomorrow. As for water in the gas, I did think about that. This is the second tank after it started happening albeit we filled up at the Shell station we usually do. With premium this last time as well.

I also need to say that this will occur running 65mph with cruise set as well as 45mph down the highway without. Just SEEMS to quit/lessen when accelerating (but don't rely on it)
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
49 Posts
confused

i had a rough idle and accel. so i cleaned fuel inj. throttle body..new fuel filter..new plugs...map sensor and cam down to a one bad coil pack.
 

·
Registered
2003 chevy trailblazer_lt_ext
Joined
·
321 Posts
Discussion Starter · #7 ·
I have thought about coil pack but was hoping it would throw a code to tell me which. I would start with #4 though if I do it. Still have to seafoam the engine first as today it was raining.
 

·
Registered
2002 olds bravada
Joined
·
2,369 Posts
If cruise control stops working suddenly, that means there is a code present, but pending. Get it scanned right away if it does happen.

Seafoam is great stuff. I used a whole can in the gas tank and half a can through he brake booster and noticed a big difference.
 

·
Registered
2003 chevy trailblazer_lt_ext
Joined
·
321 Posts
Discussion Starter · #12 ·
since its been almost 2 years I would replace it again..
Just got done seafoamin the truck. We'll see how that works out. And the fuel filter better not need replaced already, we probably have 15,000 miles on since the last one and thats it. Shell Premium is the only thing it gets.
 

·
Registered
2003 trailblazer_lt
Joined
·
9,856 Posts
Just got done seafoamin the truck. We'll see how that works out. And the fuel filter better not need replaced already, we probably have 15,000 miles on since the last one and thats it. Shell Premium is the only thing it gets.
I was surprised at how restricted mine was after only 15K, I have since made it part of my 15K service:m2:
 

·
Banned
2003 gmc envoy_slt
Joined
·
7,190 Posts
Just got done seafoamin the truck. We'll see how that works out. And the fuel filter better not need replaced already, we probably have 15,000 miles on since the last one and thats it. Shell Premium is the only thing it gets.
:eek:fftopic: Just curious: Did you have the PCM set-up for premium?
 

·
Registered
2003 chevy trailblazer_lt_ext
Joined
·
321 Posts
Discussion Starter · #18 ·
Might have to replace the fuel filter as I caught the TB 'hesitating' every once in awhile at idle. Hopefully its not a coil pack as that could be a pain to troubleshoot!
 

·
Western Canada Chapter
2003
Joined
·
6,411 Posts
I think I would buy one coil pack and then install it on the most likely culprit like #4. Then if that miss still occurs I would move it around until it goes away. (Hopefully) :m2:
 

·
Registered
2003 chevy trailblazer_lt_ext
Joined
·
321 Posts
Discussion Starter · #20 ·
I think I would buy one coil pack and then install it on the most likely culprit like #4. Then if that miss still occurs I would move it around until it goes away. (Hopefully) :m2:
This is the plan if the fuel filter doesn't work. Still waiting for it to miss/hesitate again.
 
1 - 20 of 24 Posts
Top