Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 15 of 15 Posts

·
Registered
2004 isuzu ascender
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 2004 chevy trailblazer and my head unit is a pioneer deck 50x4. My stock front door speakers work fine. But my back seat speakers dont, so I tried to replace them and the first new speaker I installed in is not working. I then checked behind the deck and all wires appear to be fine I even touched them some to see if something was lose. I checked a few fuses below my back seat but I am running out of options.

Has anyone else had this problem if so please let me know how to get my rear speakers working PLEASE? please call

Cory 918-269-9133
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
497 Posts
sounds like either a damaged wiring harness, or a faulty amp in your deck. Connect the speaker directly to the deck with some new speaker wire. If you get sound, it's a harness issue, at some point between the deck and rear speaker. If you don't get sound, your deck needs to be repaired/replaced -- and you need to consider the possibility of a short as the cause.
 

·
Registered
2003 trailblazer_lt
Joined
·
9,856 Posts
I have a 2004 chevy trailblazer and my head unit is a pioneer deck 50x4. My stock front door speakers work fine. But my back seat speakers dont, so I tried to replace them and the first new speaker I installed in is not working. I then checked behind the deck and all wires appear to be fine I even touched them some to see if something was lose. I checked a few fuses below my back seat but I am running out of options.
1 - do you have the bose system?
2 - do you have or have access to a DMM?
 

·
Registered
2008 chevy trailblazer_lt
Joined
·
619 Posts
Have you tried connecting the old speaker or a diffrent speaker to see if any sound comes out of them. Maybe the problem is the new speaker. What brand speakers are you trying to install?
 

·
Registered
2004 isuzu ascender
Joined
·
4 Posts
Discussion Starter · #8 ·
With the old stock speakers there was no sound at all,so I installed one speaker tested it and heard no music. The new speaker thats in so far is a Infinity Kappa series 62.9 speaker.
 

·
Registered
2003 trailblazer_lt
Joined
·
9,856 Posts
I do not have a bose system and no I dont have access to a DMM.

No, my deck is not faded all the way to the front.

Has anyone had this problem before?
Assuming that the new speakers are good, more then likely there is an open in the wiring between the head unit and each of the rear speakers. A DMM would help track down the fault. A few cases of broken wires in the door jam harnesses have been reported.
 

·
Registered
2008 chevy
Joined
·
129 Posts
Can you get to the back of the radio and directly connect a speaker to the wire coming out of the radio, just use a short piece of speaker wire.
This would at least let you know if there is a problem with the radio or the wiring.

Frank

P.S. I did have the fader all the way to the front problem once.
 

·
Registered
2002 chevy trailblazer_ls
Joined
·
572 Posts
so did everyone on the site get the same PM twice from this guy or was it just me?

"" Rear door speaker problem
Hey, I have a question for you.

I have a 2004 chevy trailblazer and my head unit is a pioneer deck 50x4. My stock front door speakers work fine. But my back seat speakers dont, so I tried to replace them and the first new speaker I installed in is not working. I then checked behind the deck and all wires appear to be fine I even touched them some to see if something was lose. I checked a few fuses below my back seat but I am running out of options.

Has anyone else had this problem if so please let me know how to get my rear speakers working PLEASE? please call

Cory Steward
918-269-9133
[email protected] ""
 

·
Registered
2003 chevy trailblazer_lt
Joined
·
425 Posts
so did everyone on the site get the same PM twice from this guy or was it just me?

"" Rear door speaker problem
Hey, I have a question for you.

I have a 2004 chevy trailblazer and my head unit is a pioneer deck 50x4. My stock front door speakers work fine. But my back seat speakers dont, so I tried to replace them and the first new speaker I installed in is not working. I then checked behind the deck and all wires appear to be fine I even touched them some to see if something was lose. I checked a few fuses below my back seat but I am running out of options.

Has anyone else had this problem if so please let me know how to get my rear speakers working PLEASE? please call

Cory Steward
918-269-9133
[email protected] ""
i got it too
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top