Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 4 of 4 Posts

·
Registered
2008 chevy trailblazer_lt
Joined
·
19 Posts
Discussion Starter #1
When I put the AC on and accelerate I don't have the power I do when the AC is off. When the AC is off and I accelerate it moves without any hesitation. My other 2008 Trailblazer didn't have this issue. Any ideas on what is causing this and what the fix is. Thank you
 

·
Registered
Joined
·
1 Posts
The possible problem is in the conditioner? It consumes some of the power of the car, so when you start, it would be good if the conditioner is switched off, and you can already connect it later. Or, I suppose, consume too much energy. This already has a technical problem with his, it would be good to contact a specialist in this field, or try to ask a specialized company. I know one such good company that deals with air conditioning repair servicing. You can try to address them.
 

·
Registered
2004 gmc envoy_slt
Joined
·
2,415 Posts
Bigboss, what does that have to with the OPs problem?

Rick, does the AC function well to your expectations? First thing that came to mind was that the compressor is loading down the engine. I would recommend having a HVAC mechanic diagnose your system.
 

·
Registered
Joined
·
1 Posts
That is really quite annoying, I have been having such problems as well with my AC in the car. The power keeps going off and I really was not sure what was the problem. I read up on some aircon servicing articles that it could be the car battery and I will get it checked.
 
1 - 4 of 4 Posts
Top