Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 2 of 2 Posts

·
Registered
2003 chevy trailblazer_lt
Joined
·
5 Posts
Discussion Starter #1
Hi guys, new to the forum - looks like a great place!

I have a 2003 TB and just began experiencing a problem.

Before I describe the problem, let me first state that there is also an existing problem with the ABS controller (also a well known problem) that causes the ABS motor to continuously run until the ABS fuse is pulled. The ABS controller is known to go out and I have not yet replaced this controller, but the ABS fuse has been pulled. One of these days, I'll get around to it. This causes the chimes to come on for about 20 seconds after starting, but they would always go off. The ABS and Brake warning lights remain illuminated at all times due to the ABS fuse being pulled.

Until today...

It has been very cold today - about 0 degrees F with wind chills in the -30 range. Lots of blowing snow and snow covered roads. I would switch between AWD and 4WD while driving depending on conditions.

On my return trip today, the chimes would come on whenever the truck was in motion and would stop when at a stop. No warning lights (other than the ABS stuff above) appeared. Shifting to neutral did not turn the chimes off.

The indicator lights on the 4WD switch behaved normally and the operation of the 4WD system appears to be normal.

Not sure what to make of this. Any ideas welcome!
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
52 Posts
4WD

I KNOW WHAT YOU TALKING ABOUT, but i think i've got it a little worse. From about -25C i cann't get mine to go into 4wd. Not even into Awd. Sorry still have no answers on both.
 
1 - 2 of 2 Posts
Top