Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 2 of 2 Posts

·
Registered
2002 gmc envoy_sle
Joined
·
31 Posts
Discussion Starter #1
reading this thread http://forums.trailvoy.com/showthread.php?t=122874 basically describes my problem exactly. After about 4 hrs of driving, towing a trailer total about 700lbs (trailer and cargo), in 30+ Celsius temps, using cruise control, the envoy just goes into neutral, revs spike and we are coasting. No power in D, 3 2 1. All gear selections work, ie: can shift from P to R to D to 3, 2, 1.

So we park it, shut it off, start back up, no difference, even P won't stop the truck from rolling. Coast a bit further so we are in the shade and shut it back off. Called for a tow truck, when it showed up 35 mins later, all gears worked again. Went to local mechanics, he scanned it, said only O2 sensor and fuel level unit codes stored. Drove the rest of the way home, another 2 hours, no problems. Didn't use cruise though...

A bit of googling and thinking it is likely to be planetary gear in transfer case ready to explode, or something simple like shifter cable loose or a sensor on the fritz.

Suggestions? I will be checking a few things tomorrow first thing.
 

·
Registered
2002 gmc envoy_sle
Joined
·
31 Posts
Discussion Starter #2
Transfer case fluid is right to the top hole, a nice blue colour. Shifter cable linkage is solid and secure everywhere I can check it without dismantling things. I am hoping this was a one-time event maybe due to overheating transmission or something (towing on a hot day with a loaded car). Anything else goes wrong I will follow up here.
 
1 - 2 of 2 Posts
Top