Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 4 of 4 Posts

·
Registered
2006 chevy trailblazer_lt
Joined
·
41 Posts
Discussion Starter #1
2006 6 cyl trailblazer LT off lease with 40k miles. Chicago weather and salt conditions.
now at 46k miles.

Problem:

On a cold start, pinging noise can be heard best between houses in driveway at idle. Seems to come from front seats forward. Goes away or cannot hear it as car hits normal running temp. Normal engine sounds mask noise above idle. Noise changes with rpm, and all gears, park, and neutral with brakes on. Sound is asynchronous, may sound like Morse code groups or single strikes.

Noise occurs whether Radio off or on, A/C off or on, serpentine belt off or on.

Noise sounds like a light slapping of thin stiff metal to metal. No codes found. After many searches, isolated it to best heard behind the passenger front tire.

Searching the site for similar problems led me to the exhaust area, possible cracked exhaust manifold.

Maintenance Performed:

Fan clutch
New tires - alignment
New battery.
Cleaned throttle body, new air filter.
Mobil 1 oil and GM oil filter.
New plugs and front O2 sensor.
Bilstien HD shocks front and back.
Front and rear sway bar links and bushings
Remove Passengers front child restraint lock on seat belt.
Changed front and rear diffs, transfer case, transmission filter and flush, and power steering.
Replaced serpentine belt.

Trouble shooting performed:

Pull serpentine belt. Noise still there.

Pulled air solenoid fuse 54 and air pump fuse 56, transfer case 8, Air pump relay 55 and air conditioner fuse 30 all at the same time, still hear sound

Looked at exhaust manifold visually for cracks (not done yet), need to remove shield.
Idler and tensioner pulleys need to be replaced (not done yet).
Flush Brake Fluid (not done yet).

Listening with a dowel noise seems to come from the secondary air injection check valve. Item 2 below. Is there a way I can verify this by pulling a cable plug, or do I need to remove the hoses and see if the noise goes away?



Compnine provides these part numbers:

Item Part Number RPO Code Desc
002 12583486
ST1(LL8)
VALVE,SECD AIR INJN CHK (ACDelco #214-1683)

Rock Auto part numbers do not seem to match up. Does somebody have current part numbers for this?
 

Attachments

·
Northwest Chapter
Joined
·
11,824 Posts
Sounds like typical cold lifter tap or you're hearing the injectors open/close rapidly. I would normally say switch to synthetic and it will take care of it but you already have.

Could you get a sound clip/video?
 

·
Registered
2006 chevy trailblazer_lt
Joined
·
41 Posts
Discussion Starter #4
Well, I went out to record the noise this morning and I can barely hear it. I guess I should not have banged the check valve yesterday.

The noise has been present for at least 3 - 5 months loud enough for others to hear.

If this is the problem, because sound is gone, is the check valve something requiring service soon, or can it wait for a while.

Are there more current part numbers than the ones shown on compnine?
 
1 - 4 of 4 Posts
Top