Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

21 - 29 of 29 Posts

·
Registered
2005 gmc envoy_slt
Joined
·
7 Posts
Just an FYI, this is a dealer part and should only be around $100 or so, take of the old one and clean it with dish soap first and save the money if it is not to rusted.:thumbsup:
 

·
Registered
2008 isuzu ascender
Joined
·
989 Posts
valve

Try rockauto.com for parts.
 

·
Registered
2009 chevy trailblazer_lt
Joined
·
1 Posts
Replaced Air Check Valve - Code Reappeared

My chevy 2009 trailblazer V6 had the check engine light appear a few weeks ago. Code came up P2440. I replaced the Secondary Air Check Valve (ACD # 214-2151) and reset the computer. The check engine light went away and the car ran great for about a week. The check engine light reappeared with the same P2440 code (Secondary Air Injection System shut-off valve stuck open). There is noticeable deficit with engine performance as well as dimming of interior lights with brake use. The part was correctly installed. Is there anything that could cause the valve to malfunction (i.e. electrical/computer/fuse). I've also read on other forums that the secondary air pump could throw the same code but is unlikely. Could my P2440 problem be linked to dimming light problem? Help?
 

·
Banned
2009 saab
Joined
·
138 Posts
My chevy 2009 trailblazer V6 had the check engine light appear a few weeks ago. Code came up P2440. I replaced the Secondary Air Check Valve (ACD # 214-2151) and reset the computer. The check engine light went away and the car ran great for about a week. The check engine light reappeared with the same P2440 code (Secondary Air Injection System shut-off valve stuck open). There is noticeable deficit with engine performance as well as dimming of interior lights with brake use. The part was correctly installed. Is there anything that could cause the valve to malfunction (i.e. electrical/computer/fuse). I've also read on other forums that the secondary air pump could throw the same code but is unlikely. Could my P2440 problem be linked to dimming light problem? Help?
Highly doubt you get get the answers you are looking for or even a timely response. Check out g m t n a t i o n . c o m (no spaces). The members there should be able to help you out.

Just so you know the TrailBlazer 4.2L has an I6 not a V6.
 

·
Registered
2009 chevy trailblazer_lt
Joined
·
53 Posts
I am getting the P2440 error code as well. Is the 214-2222 part number valid for the 2009 Trailblazers as well? I looked them up and it appears that they are only valid for the 2004-2005 model years.
 

·
Registered
2007 chevy trailblazer_lt
Joined
·
4 Posts
P2440 and P0455

In about the worst of our sub zero temps this past winter I began getting the p0455 large EVAP leak code and cleaned up and tightened the gas cap and it resolved itself. Now that code has returned along with the P2440. I hope replacing the gas cap will be all that is necessary to fix the first code. As far as the p2440, all of the length of hose I can inspect looks fine and secure, fuses 54 (solenoid) & 56 (pump) are good. Right at start up and throughout driving I can hear an exhaust rumble from the area of the solenoid. I can hear the pump whine upon start up and it does stop about 30 seconds in. It does not sound strained, even though I feel like I should have disconnected the hose to look for water. When I disconnect the hose from the air filter box there is moisture dripping out and exhaust blowing through. I wouldnt say that I see standing water in the air box or dripping from it but still sticking a finger in that hole will leave you with a bit of wet exhaust smelling water. Would it be pretty safe to assume that the solenoid will have to be replaced or should I still consider wiring or something else. Thanks for your help guys.
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
38 Posts
Sorry for bringing up an old thread but this issue is tiring me out.

Originally I had the P2440 error code.

I had my buddy replace the solenoid, air pump, and the relay.

After replacing these parts (ACDelco parts), I now get the P0411 error code which brings me back to square one.

Any assistance is appreciated!

Thanks!
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
38 Posts
Well I did the battery disconnect for a few hours but after a few cold starts, the check engine light came back on.

Any assistance is greatly appreciated.
 
21 - 29 of 29 Posts
Top