Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello all. I have an issue with my 02 trailblazer running hot. I get an error code P1481 and also noticed that the cooling fan isn’t spinning when the engine is running. I’ve read several posts but none have given a definitive answer to this particular issue. Any help or suggestions are appreciated. Thanks all.
 

·
Registered
Chevy Trailblazer 2008 LTZ (4.2L)
Joined
·
128 Posts
First, inspect the wiring of the electrical connection of the fan clutch
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I’m willing I try anything. What parts do I need to inspect exactly? I looked at the top harness on the fan shroud. It looks ok.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Ok. I will check in the morning. Will I have to disassemble anything? I’m fearing that I need a whole new fan clutch.
 

·
Registered
Chevy Trailblazer 2008 LTZ (4.2L)
Joined
·
128 Posts
There are many videos on the Internet about replacing a fan clutch, please study and then you will understand exactly where to look at the wiring and the connecting plug.
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
184 Posts
There is a TSB about the wires rubbing through near the fan clutch where the wires come from a connector and enter a plastic/rubber connector seen here...

IMG_20190829_105159.jpg


Also, the pins inside that connection can become loose and not connect reliably. If you have a DMM and know how to use it to troubleshoot this type of thing it's pretty straightforward.
 

·
Registered
2004 gmc envoy_slt
Joined
·
2,332 Posts
First of all, with engine off can you move fan by hand? It should move freely. With engine running, fan should at least move some because the clutch contains a viscous material that provide a little bit of friction.
 
1 - 7 of 7 Posts
Top