Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 4 of 4 Posts

·
Registered
2006 gmc trailblazer_ls
Joined
·
179 Posts
Discussion Starter #1
Ok so having a check engine light about every 100 miles of mostly p0174 bank 2 system lean. Occasionally it’s accompanied by p0171 too but not always. Was gonna start with cleaning maf and then check signal on the 02’s. Whats im starting to wonder too is if this is going along with strange tin can type noise i got under light acceleration . Here is video of noise u can really hear it near end of video.

https://youtu.be/GCT1KT_sMaY

Any help would be great.



Sent from my iPhone using Tapatalk
 

·
Registered
2006 gmc trailblazer_ls
Joined
·
179 Posts
Discussion Starter #2
Ok after taking it on lil drive after i cleared codes. Came back after only 44 miles. Here is shrt term fuel trim and long term and some other various things












Sent from my iPhone using Tapatalk
 

·
Registered
2006 gmc trailblazer_ls
Joined
·
179 Posts
Discussion Starter #3
Problem was fixed just for heads up. Changed where i got gas, ran sea-foam in tank, changed air filter and clean maf and cured my issue. Passed emissions and hasn’t come back on in over 500 miles.


Sent from my iPhone using Tapatalk
 

·
Registered
2006 gmc trailblazer_ls
Joined
·
179 Posts
Discussion Starter #4
Over 3k miles since issue fixed and has not come back. Just was finishing off the thread so if someone else ever has issue they find what worked for me. Thanks


Sent from my iPhone using Tapatalk
 
1 - 4 of 4 Posts
Top