Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 8 of 8 Posts

· Registered
2006 chevy trailblazer_ls
Joined
·
41 Posts
Discussion Starter · #5 ·
Just a update .... so I changed the oil and filter yesterday morning and un-cliped the camshaft postion sensor and re-connected it ... I was driving to work this morning and the engine light went off .... I hope this was the trick. Now I need to get a New York State inspection next month so will this pass with the light off or was something stored in the PC that I will need to get re-set to pass ?

Thanks !!
 

· Registered
2006 chevy trailblazer_ls
Joined
·
41 Posts
Discussion Starter · #7 ·
After a month of no light you should have no problem with the state inspection.:m2:
ok so on the way home from work today the light turned on again ... I can take this anymore. should I shell out the money and just buy the camshaft actuator. anyone how much it is or the part number. looks like a easy swap if I buy one.
 

· Registered
2006 chevy trailblazer_ls
Joined
·
41 Posts
Discussion Starter · #8 ·
Here we go again. I changed the camshaft actuator on 7/29/09. Everthing was then fine (check engine light went off) truck was running great. I even took a long road trip with no problems last week. Now I go to start the thing today and the check engine light is on again. I went to autozone on my lunch today and now the truck is tossing out the same P0014 code .... any sugestions anyone ?
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top