Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 4 of 4 Posts

·
Registered
2002 chevy trailblazer_ls
Joined
·
8 Posts
Discussion Starter · #1 ·
2002 - TB with a 4.3 and 115K has a running hot issue - Had A/C Run Hot prom update done at dealer - worked for about 2 weeks and now its reading past 210 like around 230 ish - installed new serp belt as well.. no clutch codes - any ideas ???? :grouphug:
 

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
2,667 Posts
2002 - TB with a 4.3 and 115K has a running hot issue - Had A/C Run Hot prom update done at dealer - worked for about 2 weeks and now its reading past 210 like around 230 ish - installed new serp belt as well.. no clutch codes - any ideas ???? :grouphug:
Contrary to popular believe, your fan clutch can be bad and it may NOT throw a code. It happened to me. There are many things on these vehicles that are SUPPOSE to work a certain way, but don't seem to!

We need a little more info - has any other work been done to the cooling system? Thermostat, coolant drained and flushed, etc.
Most of the time the thermostats on these vehicles tend to stick in the open position, but it could be your thermostat isn't opening all the way.
When you say you are getting up to 230 - is that driving on an open road or idling at say a stop light?
 

·
Registered
2002 chevy trailblazer_ls
Joined
·
8 Posts
Discussion Starter · #3 ·
Fan clutch was replaced - 2 used ones , I sell USED auto 1999-2008 parts , never did anything with the thermostat and the Coolant looks clean ( never did anything with that either . )
doesnt over heat all the time , no real method to its madness . Stop lights are the worst of it .. but its doing it on the highway as well . A/C On .. its pretty bad too
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top