Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 9 of 9 Posts

·
Registered
2002 chevy trailblazer_lt_ext
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello everyone I got a 2002 EXT 4.2L I6 and its been smooth sailing for about 5+ years its only got 124,000 miles...I know this has been just about beat to death...I have been through changing the oil pressure switch a year ago...all has been fine until just about the same time this year, I got the DIC telling me to stop engine and idiot guage flipping out...the switch was under warrenty so I have a new one installed...doing same thing but only after about an hour...so I Fabed up an adapter to take the place of the Switch and installed a mechanical guage, with copper tubing, in the dash, like I saw on this Site...and I am loosing oil pressure!!!!

So my question is this...why would a mechanical oil pump work for an hour then stop?

If I go out right now it will pump and I will get pressure on the Mechanical Guage...for about an hour...WTF...the pump is mechanical right? if the engine is running it's pumping right?

Apparently there is no replacment avaliable only a repair kit?
Anyone done this repair kit?
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
438 Posts
Just trying to save you money here before you go digging in the oil pump.

1.) What kind of oil filter are you using?
2.) What grade and type oil are you using?
3.) When was the last oil change?
4.) Are you certain the oil level is full?

There have been incidences where oil filters have failed internally, may have been defective out of the box, and can cause restriction as the engine warms up. In the process of elimination, I would change the oil & filter first. Use a high quality conventional 5w/30 or a synthetic 5w/30. Go with an AC-Delco oil filter PF-61e.

Also the I6 has gotten looked over at oil change places or by DIY-ers before as it takes 7 quarts of engine oil and not the traditional 5. Are you positive the oil if at the full mark on the dipstick?
 

·
Registered
2002 chevy trailblazer_lt_ext
Joined
·
3 Posts
Discussion Starter · #3 ·
Just had the oil changed,Valvoline 5w30 ac delco filter two days ago.
affermative on 7 Qts of oil and tripple checked the dip stick.

thinking about putting in some seafoam or Kerosene to clean out the possiable gunk.
then changing oil and filter again.
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
438 Posts
Just had the oil changed,Valvoline 5w30 ac delco filter two days ago.
affermative on 7 Qts of oil and tripple checked the dip stick.

thinking about putting in some seafoam or Kerosene to clean out the possiable gunk.
then changing oil and filter again.
Did the oil pressure problem occur before the oil change? Are you sure they changed the filter?
 

·
Registered
2002 chevy trailblazer_ss_lt
Joined
·
1 Posts
oil pump do not send pressure

hi there, ok oil pump do not make pressure at all so you know it, ok for that main bearing are for, and you can find a new oil pump at your local dealership for less tha $200 dl include it the whole time chain cover its more easy that dooing the reeplacement kit. i'll check my main bearing may be need reemplace those instead of oil pump
 

·
Registered
2002 chevy trailblazer_ltz
Joined
·
3,250 Posts
hi there, ok oil pump do not make pressure at all so you know it, ok for that main bearing are for, and you can find a new oil pump at your local dealership for less tha $200 dl include it the whole time chain cover its more easy that dooing the reeplacement kit. i'll check my main bearing may be need reemplace those instead of oil pump
What????? Is this in English?? :eek:
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
1 Posts
I see this is an old thread, but my TB with 162,000 is doing the exact same thing. Wondering if thread starter found the source of the problem or anyone else knows the likely source.

Thanks!
 
1 - 9 of 9 Posts
Top