Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 4 of 4 Posts

·
Registered
2006 chevy trailblazer_ls_ext
Joined
·
2 Posts
Discussion Starter #1
Ok so i have changed the power steering pump 3 times in a 2006 trailblazer 4x4 ext with the 4.2. The pump acts like its deadheading and the last pump got so hot that the resivoir inlet actually melted shut. So i did some investigating and found several things and have talked to multiple mechanics. 1}bad rack....2}air in the system. 3}bad pump 4} need to bleed the system at the gear... so im completely lost now. Is there a bleeder on the steering box before it goes to the rack? Or no? This all started when the pressure line started to leak. Took it to a very dependable guy he replaced the bad line. Still no ps. Replaced the pump. Still nothing. Replaced the pump again. Still nothing. Today i replaced the pump and still no power steering. Can anyone help me or has anyone else had this same problem that can point me in the right direction?????? Please help!!
 

·
Registered
2004 gmc envoy_slt
Joined
·
2,371 Posts
My "guess" would be that there is a restriction in the high pressure line, maybe the old Oring from the hose that was replaced.

Why didn't you take it back to the "dependable" guy and him fix it?
 

·
Registered
2003 chevy trailblazer_lt_ext
Joined
·
14 Posts
The rack and pinion may be bad which may have also caused the pump and line to go bad from trying to force fluid through the bad rack. That's probabaly not what you want to hear, but if the pump and lines are good, you are losing the possibility of any other part but the rack being the main problem.
 
1 - 4 of 4 Posts
Top